2

I'm using Ubuntu 14 LTS. I (fully) installed TexLive2013 then I (fully) uninstalled it in order to install TexLive2014 which I did it from an .iso file succesfully. Now I want to install an extra package: XeTex or XeLaTex & most importantly XePersian (Typesetting for Persian). I think I need tlmgr , but it wasn't provided within my original TexLive2014.iso. Ubuntu says I may get it by (re)installing texlive-base .Now the question is:

1) The texlive-base provided in Ubuntu's repos, is 2013 and I think I can't use it for my TexLive2014 (Am I right?), so how I may install tlmgr?

2) Is there any way to install this XePersian package manually. I mean copying/unzipping it somewhere? into some path? or something? Would you give me detailed command/path, please?

The XePersian package is a zip archive containing these files:

  • A folder named XePersian inside it:
    • A folder named img with some JPGs inside
    • Some python files: dkun03, dkun04, ftxe012, undk02, undk06
    • Two files: xepersian.dtx and xepersian.ins
    • A ReadMe and two PDFs
2

Texlive 2015 is now avalable.

Otherwise, run tlmgr --gui, in the tlmgr menu (up-left) you can change the texlive depot.

With the graphic interface you can search for the missing packages and install them :

enter image description here

1

First of all, Update your TexLive (As my dear friend said in comments). Then make sure you have the following packages:

  1. texlive
  2. texlive-latex-recommended
  3. texlive-generic-recommended
  4. texlive-xetex
  5. texlive-lang-arabic

Consider that you should find the packages suitable for TexLive2015. I think there are available in CTAN. Also there are couple of other recommended packages:

  • gummi (a very lightweight editor for latex)
  • texlive-lang-english (you may need it)

If it didn't help you can find some experts here.

  • Welcome to TeX.SX! Since TL 2015 is available for almost two months now, it's a little bit strange to refer to TL 2014, but the principle strategy should work. – user31729 Aug 2 '15 at 7:53
  • @ChristianHupfer He is using TexLive 2014 ... but he should be updated though. :)) – Ali Torabi Aug 2 '15 at 7:58
  • Perhaps you should recommend the update in your answer then ;-) – user31729 Aug 2 '15 at 8:06
  • @Ali Torabi I'll check your solution then I'll share results. – Vynylyn Aug 13 '15 at 17:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.