2

I have included the package amsmath as required to defined a new theorem/corollary (without number), but I keep having the following error:

! LaTeX Error: Command \* already defined.

Now, these are the packages I am including, if that can help:

\usepackage{fullpage}
\usepackage{parskip}
\usepackage{color}
\usepackage{amsfonts}
\usepackage{graphicx}
\usepackage{amssymb}
\usepackage{amsmath}
\newtheorem*{corollary}{Corollary}

And then I am tring to use the new command with:

\begin{corollary}
...
\end{corollary}
  • You need \usepackage{amsthm} in order to use \newtheorem* – egreg May 19 '15 at 21:31
  • Oh, sorry, I thought I needed amsmath... I am really tired.. – nbro May 19 '15 at 21:33
  • You do need amsmath if you're writing a mathematical document. It's just not sufficient. – egreg May 19 '15 at 21:33
2

The package you need is amsthm (besides the recommended amsmath).

Add \usepackage{amsthm} and all will go flawlessly.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.