1

I am using the empheq package to group equations organized using the align command.

If used in an article document class the left brace automatically scales wonderfully to group equations organized in an align environment.

If used in the duke dissertation document class the left brace does not scale appropriately: it is too small, which leads to the complete omission of the first line in larger groups of equations.

Why is the behavior of the auto-scaling feature inconsistent across these different document classes? What can I do to make it behave as intended in the dukedissertation document class?

I have linked to .cls files for both document classes involved as well as provided below minimal working examples for each of the two document classes.

  • article class is good:

    \documentclass{article}
    
    \usepackage{amsmath}
    \usepackage{empheq}
    
    \begin{document}
    
    \section{Section Something}
    
    Words for reference of where text would be.
    \begin{subequations}
    \begin{empheq}[left=(1.1)\empheqlbrace]{align}
    v &= \dot{x}\\
    a &= \dot{v}\\
    j &= \dot{a}
    \end{empheq}
    \end{subequations}
    More words for more reference of text location.
    
    \end{document}
    

MWEarticle

  • dukedissertation class is bad:

    \documentclass[]{dukedissertation}
    
    \usepackage{amsmath}
    \usepackage{empheq}
    
    \begin{document}
    
    \chapter{Chapter Something}
    
    A new chapter.
    
    \section{Section Something}
    
    Words for reference of where text would be.
    \begin{subequations}
    \begin{empheq}[left=(1.1)\empheqlbrace]{align}
    v &= \dot{x}\\
    a &= \dot{v}\\
    j &= \dot{a}
    \end{empheq}
    \end{subequations}
    More words for more reference of text location.
    
    \end{document}
    

MWEdukedissertation

Link to Duke webpage where LaTeX zip file containing dukedissertation.cls file can be found: dukedissertation

Direct link to article.cls file: article

2

The dukedissertation class uses a very non standard way to comply with the dreaded double spacing requirement, whereas empheq assumes the method with \baselinestretch is used to modify the interline space.

We can fix the issue by telling LaTeX to use the standard method when an empheq environment is concerned.

\documentclass[]{dukedissertation}

\usepackage{amsmath}
\usepackage{empheq}
\usepackage{etoolbox}

\AtBeginEnvironment{empheq}{%
  \par\nopagebreak\vspace{-\abovedisplayskip}
  \linespread{1.5}\selectfont\normalbaselines
}

\begin{document}

\chapter{Chapter Something}

A new chapter.

\section{Section Something}

Some text before the first equation, ensure that it breaks across a couple
of lines and extends on the second one so that the normal vertical space
is used
\begin{equation}
A+B=C
\end{equation}
Some text before the first equation, ensure that it breaks across a couple
of lines and extends on the second one so that the normal vertical space
is used
\begin{subequations}\label{thiseq}
\begin{empheq}[left=\eqref{thiseq}\ \empheqlbrace]{align}
v &= \dot{x} \\
a &= \dot{v} \\
j &= \dot{a}
\end{empheq}
\end{subequations}
More words for more reference of text location.

\end{document}

Note how to set the global number with \eqref instead of setting the explicit number.

enter image description here

  • The etoolbox package with the AtBeginEnvironment command solved my stated problem perfectly. – Bender Orszag Is Good Stuff May 21 '15 at 13:59
  • Additionally, you answered an unasked question well: The \label{} and \eqref{} suggestion is a decidedly better way of referencing equation numbers automatically than an ad hoc method I had devised: I had been using (\arabic{chapter}.\arabic{myequation}) where I defined the counter "myequation" and incremented it with every equation to keep track of overall equation numbering within the align environment. Within the align environment the innate "equation" counter took on values a, b, c, etc. and didn't produce the appropriate number. – Bender Orszag Is Good Stuff May 21 '15 at 14:10
  • @BenderOrszagIsGoodStuff Yes, when you set a \label after \begin{subequations}, it will refer to the “global“ number for the subequations. You should probably tune up the \linespread factor to really fit with the interline spacing in the other paragraphs. Possibly \linespread{1.5} is better. – egreg May 21 '15 at 14:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.