0

I have a document with about 50 tables in it. If one of the tables goes over the page, LaTeX automatically sends that table to the next page. The issue is that LaTeX increases the spacing between the remaining tables on the first page, which is not what I desire. How do I maintain a fixed vertical space between tables rather than having the spacing increase?

Example code:

\begin{table}
\begin{tabular}
 ...
\end{tabular}
\end{table}

(this repeats multiple times)

Desired output: multiple tables on some pages with equal spacing between end of one table and start of the next constant (unless next table starts on new page).

  • If you have several picture per line, perhaps you should take a look at the floatrow package. – Bernard May 20 '15 at 20:24
1

You don't give many clues but I would guess that you have \flushbottom in effect and a setting of \floatsep such as the default of 12pt plus 2pt minus 2pt

So either you need \raggedbottom so latex doesn't try to stretch out each page, or you could try setting

\setlength\floatsep {12pt}

so the inter-float separation was not flexible, although unless there is some other stretch space on the page this will lead to under full pages if \flushbottom is in use.

If you have 50 tables with no intervening text, you probably should just set them directly as minipages rather than use the float mechanism, which isn't really designed for that use case.

  • \raggedbottom still has the same issue. I tried using minipages, but minipages give \hbox too wide errors. – Arlington May 20 '15 at 20:37
  • 1
    @Arlington as I say you have given no hint as to your input or output so people can only guess. Perhaps your tables are on float pages not text pages in which case you need to set \@fpsep not \floatsep – David Carlisle May 20 '15 at 20:40
  • @Arlington minipages will not give overfull hbox errors if you do not make them too wide: again if you do not show code, we can not guess what is wrong with the code, although actually I'd guess that you neglected paragraph indentation and could put \centering before them to avoid that. – David Carlisle May 20 '15 at 20:42
  • Have updated with code. – Arlington May 20 '15 at 20:47
  • 1
    @Arlington No. sorry that code fragment isn't at all useful in debugging your problem – David Carlisle May 20 '15 at 21:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.