4

I have recently found that modern TeX Live 2014 distribution has new LuaTeX engine luajittex. As far as I know this is just experimental however if we consider that luatex is beta version, almost everything about LuaTeX is still experimental. I compile my documents with lualatex using TeXstudio editor and it uses luatex engine by default, the compilation command line in Windows is:

lualatex.exe -synctex=1 -interaction=nonstopmode -shell-escape %.tex

Up to now the lualatex works perfectly and reliably for all my documents (usually I compile tex files to pdf).

I know that some people have reported that the luajittex has faster compilation time comparing to luatex. I would like to try new luajittex engine but I could not find any information how to change the default compilation engine.

What is a compilation command line if I want to use the luajittex engine in typical TeX-to-Pdf scenario?

10
  • 3
    luajittex --fmt=lualatex test.tex works for me in the sense that there is a resulting PDF. My installation keeps on regenerating the format file, I don't know why.
    – topskip
    May 21 '15 at 5:56
  • @topskip Thank you for your comment. I tried to compile the sample document but at the first attempt I got no pdf and the following message at the end of log: I can't find the format file `lualatex.fmt' but that was problem from my side with zero-length sample file, then after fixing the problem, the 2nd attempt was successful and I got the PDF file! May 21 '15 at 6:40
  • The problem I mentioned in my previous comment was not related to zero-length sample file. It seems that is the problem with TeX paths because the first attempt I did under Windows 7, and the second one - under Ubuntu 14.04. May 21 '15 at 7:00
  • @topskip: The default setting in TL15 disables the luajitlatex format in fmtutil.cnf, but you can enable it e.g. by creating a local fmtutil.cnf see preining.info/blog/2015/04/tex-live-the-new-multi-fmtutil. Worked fine for me. May 21 '15 at 7:57
  • 3
    Find your fmtutil.cnf with kpsewhich fmtutil.cnf. Open it and enable the luajitlatex format by removing the #! . Then create the format with fmtutil-sys --byfmt luajitlatex. Then you should be able to use luajitlatex test. May 21 '15 at 9:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.