36

I'm trying to create a simple invoice with pdflatex and the isodoc class. Unfortunately, the "INVOICE" opening is appear in all lowercase, and I suspect this warning is the reason why:

LaTeX Font Warning: Font shape `T1/lmr/bx/sc' undefined
(Font)              using `T1/lmr/bx/n' instead on input line 19.

My best guess at this cryptic output is that LaTeX doesn't know how to represent small caps. What can I do to teach it how?

Here is the preamble of my document:

\documentclass{isodoc}
\usepackage[latin1]{inputenc}
\usepackage[T1]{fontenc}

The system is Fedora Core 4 . pdflatex -version yields:

pdfeTeX 3.141592-1.21a-2.2 (Web2C 7.5.4)
kpathsea version 3.5.4

And:

$ rpm -qa | grep tex
tetex-dvips-3.0-10.FC4
tetex-fonts-3.0-10.FC4
tetex-3.0-10.FC4
tetex-latex-3.0-10.FC4
passivetex-1.25-5
gettext-0.14.3-1
xmltex-20020625-5.2
texinfo-4.8-8.fc4.2

I asked this 12 and a half years ago, and I am still quite surprised that every response assumes that I wrote the code that is failing, when it was actually within the isodoc class. I don't know under what use and environment the isodoc class was built to succeed.

There have been many updates since then. I'm not using tex anymore, and I don't know wjether the issue still presents.

1
  • Coming back to this a decade or two later, there must have been a font that isodoc was built and used with, that can be specified in the header to make it work correctly. I wonder what would have happened if I’d left out the T1 selection. Most of the times I returned I didn’t remember or realize that line was setting the font used by the isodoc class.
    – fuzzyTew
    Jan 28 at 4:11

2 Answers 2

44

The error/warning is fairly self explanatory if you know what to look at.

T1/lmr/bx/sc refers to a specific font declaration:

T1 — so-called ‘Cork’ font encoding
lmr — ‘Latin Modern Roman’ font family
bx — bold
sc — small caps

By saying this font shape is "undefined" simply means that the Latin Modern Roman doesn't have bold small caps. As a fall-back, the default bold font is chosen instead.

As you've now discovered, not writing \bfseries\scshape in the first place will resolve the warning :)

8
1

I managed to partially work around this by altering the invoice text. I found it defined in the isodoc source with:

\def\invoicetext{{\bfseries\Large\scshape invoice}}

Adding the following after my document setup removed the use of small capitals:

\def\invoicetext{{\bfseries INVOICE}}
2
  • It seems you intended to use \uppercase{} instead of \scshape...
    – strpeter
    Nov 15, 2018 at 13:51
  • @strpeter the code came from the 3rd-party isodoc class, as mentioned in the question. I just needed it to work quickly. Not sure what the intended environment was for isodoc ... it didn't seem to function quite properly in my default environment.
    – fuzzyTew
    Jan 7, 2019 at 17:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .