2

I'm trying to use the Roboto font in a beamer presentation, built with pdftex. I installed the roboto package, but when trying to build, I get the following error:

Trying to make PK font Roboto-Light-lf-t1--base at 657 DPI...
Running miktex-makemf.exe...
miktex-makemf: The Roboto-Light-lf-t1--base source file could not be found.

Running ttf2pk.exe...
miktex-makepk: PK font Roboto-Light-lf-t1--base could not be created.
)
!pdfTeX error: pdflatex.EXE (file Roboto-Light-lf-t1--base): Font Roboto-Light- lf-t1--base at 657 not found

I tried running updmap.exe in a console, both as user and admin, but it didn't resolve the problem. An MWE is included below.

\documentclass{beamer}

\usepackage[T1]{fontenc}
\usepackage[sfdefault,light]{roboto}

\title{Title}
\author{Me}

\begin{document}

\maketitle

\begin{frame}
 \frametitle{First slide}
 \begin{itemize}
  \item Item
  \item Item
 \end{itemize}
\end{frame}

\end{document}

Update: I just tried updating my packages and saw that the roboto package is obsolete. Could this have something to do with the error? Does this mean I can't use the font?

closed as off-topic by user36296, ebosi, Przemysław Scherwentke, Zarko, Werner Dec 19 '16 at 17:53

  • This question does not fall within the scope of TeX, LaTeX or related typesetting systems as defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Which tex system do you use? – Ulrike Fischer May 22 '15 at 19:19
  • @UlrikeFischer MiKTeX 2.9 with the TeXworks editor. – Mangara May 22 '15 at 19:33
  • I can use the font without problems (and my system is up-to-date). Perhaps the package has been renamed. Synchronize in the package manager (user and admin) in the repository menu your package database and run updates. Run also updmap. – Ulrike Fischer May 22 '15 at 21:54
  • 1
    @Stormie Not with pdftex. I ended up switching to XeTeX, which was quite painless and made this very easy (it can use system fonts). – Mangara Feb 9 '16 at 20:21
  • 4
    I'm voting to close this question as off-topic because solved by switching to xelatex – user36296 Dec 19 '16 at 17:05

Browse other questions tagged or ask your own question.