2

It just does not work, no matter how I try. Currently I use

\bibliography{lit.bib}

before starting the document, then

\printbibliography{lit.bib}

before ending it. I can refer to entries in the bibliography just fine in text, the references will be made and named as they are in the bibliography, however the page on which I put the \printbib... command simply says "lit.bib"

What am I doing wrong?

I'm using pdflatex+makeindex+bibtex

Edit:

\documentclass[english,parskip=half]{scrartcl} 

\usepackage[utf8]{inputenc} 
\usepackage{chngcntr}
\usepackage{babel} 
\usepackage{lmodern} 
\usepackage[T1]{fontenc}
\usepackage{microtype} 
\usepackage{graphicx} 
\usepackage{csquotes} 
\usepackage[output-decimal-marker={,},exponent-product=\cdot]{siunitx} 
\usepackage{tabularx} 
\usepackage{mathtools,amssymb} 
\usepackage[section]{placeins} 


%\def\fps@figure{htbp}
%\def\fps@table{htbp}

\usepackage[colorlinks=true,allcolors=black]{hyperref} 
\bibliography{lit.bib} 
\addbibresource{lit.bib}



\addto\extrasenglish{%  
 \def\subsectionautorefname{Abschnitt} von Unterabschnitt auf Abschnitt
 \def\figureautorefname{Abb.} 
} 


\begin{document}

\begin{titlepage}
\centering

(Stuff from titlepage here)

\end{titlepage}

\tableofcontents
\clearpage
\input{chapter/Abstract}
\newpage
....(more chapters here
\printbibliography{lit.bib}
\end{document}

Edit Nr 2: Current code:

\documentclass[english,parskip=half]{scrartcl}


\usepackage[utf8]{inputenc}
\usepackage{chngcntr}
\usepackage{babel} 
\usepackage{lmodern} 
\usepackage[T1]{fontenc} 
\usepackage{microtype} 
\usepackage{graphicx} 
\usepackage{csquotes} 
\usepackage[output-decimal-marker={,},exponent-product=\cdot]{siunitx}
\usepackage[sorting=none]{biblatex}
\usepackage{tabularx} 
\usepackage{mathtools,amssymb} 
\usepackage[section]{placeins} 

\usepackage[backend=bibtex]{biblatex}

%\def\fps@figure{htbp}
%\def\fps@table{htbp}

\usepackage[colorlinks=true,allcolors=black]{hyperref} 
\addbibresource{lit.bib}



\addto\extrasenglish{%  
 \def\subsectionautorefname{Abschnitt}
 \def\figureautorefname{Abb.}
} 


\begin{document}
\begin{titlepage}

(content of title page here)

\end{titlepage}
\tableofcontents
(chapters here)
\nocite{*}
\printbibliography
\end{document}

Version nr 2 gives the error "option clash for package biblatex"

  • Welcome to TeX SX! A minimal (non)working example would help to help. Dib you run bibtex or biber? The normal cycle is pdflatex -> bibtex/biber -> pdflatex -> pdflatex. It seems that you use biblatex. In such a case, you should add to your preamble: \addbibresource{lit.bib} rather than \bibliography, and simply write printbibliography (no argument \ tat's why you find ‘lit.bib’ in your .pdf)). – Bernard May 24 '15 at 18:53
  • I just tried out the cycle you described and nothing changed, although I also did not get any error messages so it appears to compile "correctly" – user78853 May 24 '15 at 18:57
  • What does the .blg file say? – Bernard May 24 '15 at 18:58
  • There is no .blg file ?! – user78853 May 24 '15 at 19:02
  • Looks like you are failing to run Biber, which is the standard 'back-end' for biblatex. See for example tex.stackexchange.com/questions/63852/… and tex.stackexchange.com/questions/154751/… for some guidance. – Joseph Wright May 24 '15 at 19:04
2

You are mixing commands form bibtex and biblatex. If you use biblatex (i.e., \usepackage[...]{biblatex}, then the first command should be \addbibresource{lit.bib} and at the place where you want your bibliography printed, use \printbibliography. Nowadays, the default engine is biber (instead of bibtex, so you want to use bibtex you have to add backend=bibtex option to biblatex, \usepacakge[backend=bibtex]{biblatex}).

If you do not use biblatex, then you should use \bibliographystyle{...} and \bibliography{lit}.

  • Trying to use \usepackage[...]{biblatex} gives me the error "Option clash for package biblatex" – user78853 May 24 '15 at 19:04
  • I used ... to indicate there are some options (which I don't know since there is no minimal working example. Remove \bibliography{lit.bib} and add \usepackage[backend=bibtex]{biblatex}, and remove {lit.bib} from \printbibliography – Guido May 24 '15 at 19:07
  • Still doesn't work. It just creates an empty page with the words "lit.bib" – user78853 May 24 '15 at 19:11
  • you have to add \usepacakge[backend=bibtex]{biblatex} before \addbibresource{lit.bib}, and remove \bibliograpahy{lit.bib} and {lit.bib} after \printbibliography, and include a \cite command. – Guido May 24 '15 at 19:22
  • you have two lines with \usepackage[...]{biblatex}. combine them in a single one, I.e., \usepackage[sorting=none,backend=bibtex]{biblatex} – Guido May 24 '15 at 20:56
0

Your (modified) code, slightly more minimal than what you posted, runs fine on my system. I also corrected the syntax and I obtain a .blg file, so try this:

\documentclass[english,parskip=half]{scrartcl}

\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage{lmodern}
\usepackage{babel}
\usepackage{microtype}
\usepackage{csquotes}
\usepackage{biblatex}

\usepackage[colorlinks=true,allcolors=black]{hyperref}
\addbibresource{lit.bib}

\begin{document}

\addto\extrasenglish{%
 \def\subsectionautorefname{Abschnitt} von Unterabschnitt auf Abschnitt
 \def\figureautorefname{Abb.}
}
....(more chapters here)

\nocite{*}
\printbibliography

\end{document} 
  • Disregard, made a mistake. Still compiles fine, still no biblopgraphy :/ – user78853 May 24 '15 at 20:12
  • You're supposed to have a lit.bib file. If you have no .bib file, you can't hope to print a bibliography. – Bernard May 24 '15 at 20:16
  • Of course I do, and there's an entry I can cite even. – user78853 May 24 '15 at 20:39
  • OJ Can you post a minimal working example that shows the problem. – Bernard May 24 '15 at 20:43
  • Put a second edit into my original topic – user78853 May 24 '15 at 20:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.