1

I'm creating a report in which on the first page all the footnotes are same so I'm using \footnote for the first one and then replicating it with\footnotemark[]. However on the second page there are two separate footnotes, the first one that i'm marking using \footnotemark[] from the previous page and a second one which I have declared using \footnote{}. But on the second page it is only showing the second footnote and not the first one in the footer. Any comments?

\documentclass[12pt]{report}
\usepackage{fancyhdr}
\pagestyle{fancy}
\renewcommand{\headrule}
{
\hrule width \textwidth height 1pt}
\usepackage{scrextend}
\usepackage{multirow}
\usepackage[stable]{footmisc}
\usepackage[document]{ragged2e}
\usepackage[T1]{fontenc}
\usepackage{booktabs}
\usepackage{array}
\usepackage{geometry}
\usepackage{graphicx}
\graphicspath{ {images/} }
\renewcommand\thesection{\arabic{section}}
\geometry{a4paper, margin=0.8in}
\usepackage{amsmath}
\setlength{\parskip}{0.1em}
\usepackage{enumitem}
\setlength{\topmargin}{-0.6in}
\setlength{\footskip}{20pt}
\usepackage{titlesec}
\renewcommand{\footnoterule}
{
  \kern -20pt
  \hrule width \textwidth height 1pt
  \kern 6pt
}

\begin{document}

\subsection{Budget\footnotemark[1] \footnotetext[1]{First footnote.}}

\end{document}

1 Answer 1

1

You are going to have to duplicate the footnote in a manual way using a combination of \footnotemark and \footnotetext:

enter image description here

\documentclass{article}
\usepackage[paper=a6paper]{geometry}% Just for this example
\usepackage[nopar]{lipsum}% Just for this example
\begin{document}

\footnote{First footnote.}\lipsum[1]\footnotemark[1]

\clearpage

\footnotemark[1]\footnotetext[1]{First footnote.}\lipsum[2]\footnote{Second footnote.}

\end{document}
5
  • Ah! I was thinking that manual entry can be an option, just wanted to see if any other options was there. Thanks :)
    – novice2020
    Commented May 26, 2015 at 20:33
  • I entered the "\footnotemark[1]\footnotetext[1]{First footnote.}\lipsum[2]\footnote{Second footnote.} " and my latex is crashing with the error TeX capacity exceeded, sorry [input stack size=5000]. \reserved@a ->\def \reserved@a *{\ttl@assign@i {\@tempskipb }}\reserved@a l.113 ...et\footnotemark[1]\footnotetext{sasdasd}}
    – novice2020
    Commented May 26, 2015 at 20:48
  • @pythonnewbie: Perhaps clear all your auxiliary files (delete them) and compile/try again. If the problem persists, you need to provide us with a way to reproduce your problem (perhaps edit your question and include code that replicates it).
    – Werner
    Commented May 26, 2015 at 20:51
  • \subsection{Budget\footnotemark[1] \footnotetext[1]{First footnote.}} This is the command i'm using. Can enter the whole code if it helps
    – novice2020
    Commented May 26, 2015 at 20:54
  • @pythonnewbie: Ahhh, footnotes in a sectional command. Not a good idea, since the contents is pushed to the ToC as well. Try \subsection[Budget]{Budget\footnotemark[1]\footnotetext[1]{First footnote.}}.
    – Werner
    Commented May 26, 2015 at 20:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .