7

I am using latex to hyperlink my citations in an article. The problem is that it links figures, equations and sections numbers but not citation links. Here's a MWE,

\documentclass[letterpaper, 10 pt, conference]{ieeeconf} 
\IEEEoverridecommandlockouts                              
\overrideIEEEmargins                                     % Needed to meet printer requirements.
\usepackage{hyperref}                                   %hyperlink your equations and figures and sorts
\usepackage{times}                                       % assumes new font selection scheme installed
\usepackage{amsmath}                                    %assumes amsmath package installed
\usepackage{amssymb}                                     % assumes amsmath 
\usepackage[export]{adjustbox}
\usepackage{footnote}
\hypersetup{linkbordercolor=green}

\title{\LARGE \bf
Some Title*
 }

\author{Author One$^{1}$, Author 2$^{2}$    % <-this % stops a space
\begin{document}
\long\def\/*#1*/{}                              % Define block comment

\graphicspath{ {Chart and Figures/} }

\maketitle
\thispagestyle{empty}
\pagestyle{empty}


  %%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
\begin{abstract}
Some Random Abstract.

{\textit{Index Terms} - Life Science and Health Care; Mechatronics; Emerging      Topics in Automation }
\end{abstract}   %%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
\section{Introduction}

Results from the clinical studies \cite{cervino, c2, c3} serve as motivation   for minimizing patient positioning errors during IGRT in order to minimize   positioning-related uncertainties in cancer dose treatments, improve tumor   control, and reduce toxicity \cite{c4, c5}.

\begin{thebibliography}
\bibitem{cervino} Cervino, L.I., Pawlicki, T., Lawson, J.D., Jiang, S.B., Frame-less and mask-less cranial stereotactic radiosurgery: a feasibility study. Phys. Med. Biol. 55 (2010) 1863-1873.
\bibitem{c2} Xing, L., Dosimetric effects of patient displacement and  collimator and gantry angle misalignment on intensity modulated radiation  therapy. Radiother Oncol, 2000. 56(1): p. 97-108.
\bibitem{c3} Manning, M.A., et al., The effect of setup uncertainty on normal tissue sparing with IMRT for head-and-neck cancer. Int J Radiat Oncol Biol Phys, 2001. 51(5): p. 1400-9.
\bibitem{c4} Hong, T.S., et al., The impact of daily setup variations on head-and-neck intensity-modulated radiation therapy. Int J Radiat Oncol Biol Phys, 2005. 61(3): p. 779-88.
\bibitem{c5} Den, R.B., et al., Daily image guidance with cone-beam computed tomography for head-and-neck cancer intensity-modulated radiotherapy: a prospective study. Int J Radiat Oncol Biol Phys, 2010. 76(5): p. 1353-9.

\end{thebibliography}

\end{document}

But I find that my \cite citations are not hyper-ref'd. Is there a workaround this? Would appreciate your help. Thank you!

  • Usually hyperref should be imported last, you could try that. – Matt May 27 '15 at 22:43
  • @Matt Tried that. No luck! – Calorified May 28 '15 at 6:10
6

It has been 2 years since this question was asked, but I will write my solution because I had the same problem.

As suggested by many, hyperref should be imported last. I also tried that but failed to hyperlink my citations in the document. So, the problem is with the ieeeconf.cls. If you open it with the latex editor you are using you'll see the following:

% 2) Provide a fake nabib command \NAT@parse so that hyperref will not
%    interfere with the operation of cite.sty. However, as a result citation
%    numbers will not be hyperlinked. Also, natbib will not be able to work
%    with IEEEtran. However, this is perhaps the best solution until cite.sty
%    and hyperref.sty are able to co-exist with each other.
%    It easy enough to override the fake command via:
%    \makeatletter
%    \let\NAT@parse\undefined
%    \makeatother

Here is my example:

\documentclass[letterpaper, 10 pt, conference]{ieeeconf} 
\IEEEoverridecommandlockouts                              
\overrideIEEEmargins                                     % Needed to meet printer requirements.

\usepackage{times}                                       % assumes new font selection scheme installed
\usepackage{amsmath}                                    %assumes amsmath package installed
\usepackage{amssymb}                                     % assumes amsmath 
\usepackage[export]{adjustbox}
\usepackage{footnote}

\makeatletter
\let\NAT@parse\undefined
\makeatother
\usepackage{hyperref}  %hyperref still needs to be put at the end!

\title{\LARGE \bf
Some Title*
}

\author{Author One$^{1}$, Author Two$^{2}$    % <-this % stops a space
\begin{document}
   \maketitle
\thispagestyle{empty}
\pagestyle{empty}

\begin{abstract}
 Some Random Abstract.
\end{abstract}

\section{Introduction}

 Results from the \cite{a}, \cite{b}, \cite{c} serve as motivation...

\begin{thebibliography}
\bibitem{a} First reference
\bibitem{b} Second reference
\bibitem{c} Third reference

\end{thebibliography}

\end{document}  

enter image description here

I just included the three lines suggested in the cls file. As Schweinebacke remarked, this is for the old version of ieeeconf.cls.

  • This is about the old ieeeconf.cls not the current IEEEconf.cls from IEEEconf, isn't it? – Schweinebacke Oct 16 '17 at 7:08
  • Would be good to add a minimal working example to show that this works. – Andrew Oct 16 '17 at 7:19
  • @Shweinebacke, you are correct. But in my case, I just downloaded the ieeeconf.cls file from the conference website. Apparently, they use the old version. So, probably just updating the files works. – Ilbant Oct 16 '17 at 8:21
  • awesome! thanks for figuring this out! This fixes the problem for ieeeconf.cls. I did not realize there is an up-to-date version called IEEEconf.cls. – Calorified Oct 16 '17 at 15:42
4

Your code contain several errors. In my MWE below I corrected them. The main errors are marked with <============.

Some remarks:

  • The hyperref has to be (except in rare cases) the last package in the preamble.
  • Your command \begin{thebibliography} is not correct. It has to has a length parameter for the labels like \begin{thebibliography}{99}.
  • The \bf is outdated. Use \textbf{...} instead or \bfseries.
  • I commented your two IEEE commands, they are unknown in the class I have.
  • Your command \author{} was not closed with a }.
  • Define block element is not needed for the MWE (BTW: Why do you use it?)
  • Preamble of your MWE contain several packages (amsmath, footnote, ...) not used in your code. Since they are not related to the your problem, you can omit them!

MWE:

\documentclass[letterpaper, 10 pt, conference]{ieeeconf} % IEEEconf
%\IEEEoverridecommandlockouts                              
%\overrideIEEEmargins     % Needed to meet printer requirements.

\usepackage{times}    % assumes new font selection scheme installed
\usepackage{amsmath}  % assumes amsmath package installed
\usepackage{amssymb}  % assumes amsmath 

\usepackage{xcolor} % <======================================= for green
\usepackage[export]{adjustbox}
\usepackage{footnote}

\usepackage{hyperref} % <====================== last packge to be called
\hypersetup{linkbordercolor=green}

\title{\LARGE 
\textbf{Some Title}*
 }

\author{Author One$^{1}$, Author 2$^{2}$} % <================= missing }

\begin{document}
\long\def\/*#1*/{}                              % Define block comment

\graphicspath{ {Chart and Figures/} }

\maketitle
\thispagestyle{empty}
\pagestyle{empty}

\begin{abstract}
Some Random Abstract.

{\textit{Index Terms}~-- Life Science and Health Care; Mechatronics; 
Emerging      Topics in Automation}
\end{abstract}

\section{Introduction}

Results from the clinical studies \cite{cervino, c2, c3} serve as 
motivation   for minimizing patient positioning errors during IGRT in 
order to minimize   positioning-related uncertainties in cancer dose 
treatments, improve tumor   control, and reduce toxicity \cite{c4, c5}.

\begin{thebibliography}{99} % <==================== length missing! {99}
\bibitem{cervino} Cervino, L.I., Pawlicki, T., Lawson, J.D., Jiang, S.B., Frame-less and mask-less cranial stereotactic radiosurgery: a feasibility study. Phys. Med. Biol. 55 (2010) 1863-1873.
\bibitem{c2} Xing, L., Dosimetric effects of patient displacement and  collimator and gantry angle misalignment on intensity modulated radiation  therapy. Radiother Oncol, 2000. 56(1): p. 97-108.
\bibitem{c3} Manning, M.A., et al., The effect of setup uncertainty on normal tissue sparing with IMRT for head-and-neck cancer. Int J Radiat Oncol Biol Phys, 2001. 51(5): p. 1400-9.
\bibitem{c4} Hong, T.S., et al., The impact of daily setup variations on head-and-neck intensity-modulated radiation therapy. Int J Radiat Oncol Biol Phys, 2005. 61(3): p. 779-88.
\bibitem{c5} Den, R.B., et al., Daily image guidance with cone-beam computed tomography for head-and-neck cancer intensity-modulated radiotherapy: a prospective study. Int J Radiat Oncol Biol Phys, 2010. 76(5): p. 1353-9.

\end{thebibliography}

\end{document}

and the result:

enter image description here

I would suggest to use biblatex with a bib file.

  • Interesting. I tried your suggestions doing everything you have commanded :). I still got the pdf without link borders. Maybe it has something to do with my Latex setup. I am using TeXstudio, if it helps. – Calorified Nov 26 '15 at 4:30
  • Okay. I will check later this evening. Got to finish up a project right now. – Calorified Dec 13 '15 at 20:30
  • I have no idea why it does not come out after trying all your suggestions. I bow out --ungracefully! – Calorified Apr 24 '16 at 1:40
0

I know this is not the answer to the original question, but it might still save someone a couple of minutes:

  • Another reason for links not appearing can be that the document is in draft mode. Double check that this is not the case \documentclass[draft,...]{...}
New contributor
Martin R. is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.