4

This question may be easy, but I am stuck with some PDF pages trying to include them in my document. The normal way for pdflatex is just to insert the lines:

\usepackage{pdfpages} % in the preamble 
.
.
.
\includepdf[pages={<range>}]{filename.pdf} % in body

For pure latex.exe, I was unable to find a corresponding method. For some good reason, I use the sequence LaTeX->DVI->PS->PDF to generate my PDF. There are a number of posts also giving the same advice like this post and this.

I have tried to insert separate pages as .eps images, but this created many problems as each image has a full page size, besides being very tedious to convert a big range of PDF pages. Thank you for your advice.

My current code looks like this:

\documentclass[a4paper,12pt]{book}
\usepackage[T1]{fontenc}
\usepackage{textcomp}
\renewcommand{\rmdefault}{ptm}
\usepackage[scaled=0.92]{helvet}
\usepackage{mathtools}
\usepackage[subscriptcorrection,zswash,straightbraces]{mtpro2}
\usepackage{bm}

\usepackage{graphicx,rotating,setspace}
\usepackage{tikz}   
\usetikzlibrary{calc}
\usepackage{array,booktabs}
\usepackage{xcolor,multirow}
\usepackage[top=25mm,bottom=25mm,right=25mm,left=35mm]{geometry}    
\usepackage{microtype}
\usepackage[colorlinks=false, pdfborder={0 0 0}]{hyperref}
\usepackage{cleveref}
\begin{document}

The whole document goes here ...

\end{document}

UPDATE: As per @UlrikeFischer request:

You can find a complete example with output .PDF, .tex and .log files here. Kindly test the attachments.

  • 1
    It’s likely to be impossible to include PDF files in your document if you’re producing PostScript first. As you’ve found out, converting to EPS first would work, but apparently it’s inconvenient for you. What exactly is the reason why you have to produce DVI first? – Arthur Reutenauer May 27 '15 at 6:00
  • 1
    I am submitting an important work which is required to be typeset with high quality and the fonts should be embedded. That's why I choose the LaTeX->DVI->PS->PDF sequence. I tried pdflatex but the quality is not acceptable. – AboAmmar May 27 '15 at 6:06
  • 1
    @AboAmmar Direct PDF output should give just as good quality as the 'traditional' route, but the reasons you've got an issue are a different question. – Joseph Wright May 27 '15 at 6:33
  • 1
    It sounds like you’re having a bitmap font problem. This can usually be solved. I suggest you ask a question about that, describing what font you’re using exactly, rather than trying to work around the problem. – Arthur Reutenauer May 27 '15 at 6:33
  • 1
    @JosephWright The direct PDF output is good on screen only. On paper, the letters are distorted if you make a close look, especially, the letters: o, a, fi, d ... but when I use the traditional method I can use True Type fonts of high quality. – AboAmmar May 27 '15 at 6:39
8

As I already wrote in a comment: the most probable source for a difference between the pdflatex and the latex+dvips route is not embedded fonts.

Your pdfs show exactly this difference. pdflatex embeds fonts for the text (nimbus in this case, "eingebettet" means embedded):

enter image description here

But dvips doesn't, so the fonts provided by "the system" are used:

enter image description here

On my system and with my printer I can't see a difference between both, but it is naturally possible that something in your printing chain handles a pdf without embedded font better.

You can avoid embedding the fonts with pdflatex by setting the suitable option in updmap.cfg in miktex:

Run on the command line:

initexmf --edit-config-file updmap

An editor will open your local updmap.cfg. Enter:

pdftexDownloadBase14 false

Save the file. Then run on the command line:

updmap

to update your map-files.

But before doing this, read the remark regarding this option in the main updmap.cfg:

#
# pdftexDownloadBase14
#
# Should pdftex download the base 14 pdf fonts? Since some configurations
# (ps / pdf tools / printers) use bad default fonts, it is safer to download
# the fonts. The pdf files will get bigger, though.
# Valid settings are true (download the fonts) or false (don't download
# the fonts).
pdftexDownloadBase14 true
  • 2
    Wow, well done! We got there in the end :-) – Arthur Reutenauer May 27 '15 at 12:14
  • 1
    @UlrikeFischer Thanks a ton, Madam. You're awesome! One last inquiry, though, are you sure you didn't see any defects using your printer? in that case I can print elsewhere. For all other people here, thank you for your time. Can you please examine printing on paper? Your feedback is highly appreciated. – AboAmmar May 27 '15 at 21:09
  • 1
    @AboAmmar If Ulrike’s answer addressed your problem, could you please edit your question to reflect the actual question that she answered? It really doesn’t have anything to do with pdfpages any more, and this discussion may be useful to other people in the future. – Arthur Reutenauer May 28 '15 at 19:49
  • @ArthurReutenauer I agree. Thanks. BTW, did you examine printing my PDF files? – AboAmmar May 28 '15 at 20:01
  • @AboAmmar No, as it seemed Ulrike had addressed your problem, but I can print them at work tomorrow. – Arthur Reutenauer May 28 '15 at 20:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.