1

I'm using Writer2Latex to convert my .odt file, created in Google Docs and downloaded as .odt format, to .tex. It works but because there is no way to create columns of text in Google Docs other than using tables, the resulting .tex file conversion displays the table borders.

I have set the table border color to white, and have also set it to 0pt, the .odt file is fine once downloaded but the .tex file has some issues.

Is there a configuration setting/option/entry for Writer2Latex that will convert the formatting of the table from .odt to .tex? i.e get rid of the table border/set it to white/reduce border size to 0?

.odt odt border format

.tex tex border format

The config file i'm using at the moment:

<?xml version="1.0" encoding="UTF-8"?>

<config>
  <option name="documentclass" value="article" />
  <option name="formatting" value="convert_all" />  
  <option name="use_supertabular" value="true" />  

  <custom-preamble>\input{input/inputfile}
  \sloppy</custom-preamble>  

</config>
1
  • There are other formatting issues I'm trying to sort out too like spacing the tables, even using the use_supertabular option does not break the tables at the page breaks.
    – David
    May 27 '15 at 19:17
1

I figured it out, but now all tables have border 0pt. This is no good for mixed content with multiple columns and tables.

 <custom-preamble>     
 \setlength\arrayrulewidth{0pt}
 </custom-preamble>
1
  • I have now stopped using Google Docs to create the columns using tables, instead I used LibreWriter to create the document with columns and tables, then Writer2Latex provides the appropriate format for the .tex file. Without the need to use a preamble option in the Writer2Latex config file.
    – David
    May 29 '15 at 8:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.