4

I'm getting this error and don't know how to fix it. Is there some way to specify a different package repository? I'm no expert on MikTex so I was hoping there was something easy. I tried running the install file again to see if there was an option but it won't overwrite/modify the old installation.

This is MikTex 2.9 on 64-bit Windows 7 Service Pack 1.

The two prior questions (package install changepage and choosing package repository) that seem to mention my problem were both closed by admins as "too localized". :-(

  • 1
    Go to Update MiKTeX wizard, select I want to get updated packages from remote repository. The select Let me choose a remote package repository and then click on Connection settings. This will open window with list of all CTAN mirror, from which you can update your packages. If you like to obtain particular package, than use MiKTeX Package Manager. There you also can change remote repository. – Zarko May 28 '15 at 2:47
  • Zarko, when I click on "Connection settings", a small dialog offering the option of using a "proxy server" and asking for an "Address" appears, not a list of all CTAN mirrors... – user118967 Aug 4 '17 at 6:31
  • Correction: there is no need to click on "Connection settings", which opens a small dialog offering the option of using a "proxy server" and asking for an "Address" appears, not a list of all CTAN mirrors. To see the list, click on "Next". – user118967 Aug 4 '17 at 6:43
1

Go to Repository>Synchronize and synchronize your packages. Worked like a charm for me. Apparently this could be caused by having an outdated Miktek version, but I didn't need to update this.

  • 5
    I am having the same problem as the questioner, and this solution does not work for me. I get the same error when I do this. – BobTheAverage Aug 8 '17 at 14:59
0

If synchronize does not work, then go to -> change package directory, and tick -> packages shall be installed on the internet, then you can synchronize your packages and repository.

  • Does this answer the question? As far as I can tell, it doesn't. But I don't know much about MikTeX. – cfr Nov 13 '17 at 1:29
  • If you do not know MikTeX much, how can you tell it does not help? Have you tried it? Lazy comment. – Shizhe Zang Jan 9 '18 at 3:31
  • I was trying to prompt you to explain how this is supposed to address the problem, since it is not obvious to me and, so, probably not obvious to at least some other readers. What underlying problem does your suggestion address? – cfr Jan 9 '18 at 4:16
  • Look at the first answer and its reply – Shizhe Zang Jan 9 '18 at 4:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.