1

I'm going to use a lot of definitions in my work, so I want to create the glossary. I've found the example here .

I have a file words.tex where definitions are situated:

\newglossaryentry{r0}{name=\glslink{R0}{\ensuremath{R_{0}}},text=F\"{o}rster distance,description={F\"{o}rster distance, where 50\% ...}, sort=R}
\newglossaryentry{kdeac}{name=\glslink{R0}{\ensuremath{k_{DEAC}}},text=$k_{DEAC}$, description={is the rate of deactivation from ... and emission)}, sort=k}
\newacronym{ddye}{D$_{\text{dye}}$}{donor dye, ex. Alexa 488}
\newacronym[description={\glslink{r0}{F\"{o}rster distance}}]{R0}{$R_{0}$}{F\"{o}rster distance}

main.tex:

\documentclass[a4paper,14pt]{extbook} 
    \usepackage[T2A]{fontenc}
    \usepackage[utf8]{inputenc} 
    \usepackage[english,russian]{babel}

     \usepackage[unicode]{hyperref} % Гиперссялки
     \hypersetup{
        colorlinks = true,
        linkcolor = MidnightBlue,
        urlcolor = [rgb]{0,0,1},
        citecolor = red
     }
    ...

    \usepackage[style=long,nonumberlist,toc,xindy,acronym,nomain]{glossaries}
    \makeglossaries
    \usepackage[xindy]{imakeidx}
    \makeindex

    \loadglsentries[main]{words}

    \begin{document} 


    \glsaddall
    \appendix
    \bibliographystyle{plainnat}
    \bibliography{bibtex}
    \printindex
    \printglossaries
    \end{document}

When I'm trying to compile it, I get it:

! Package glossaries Error: Glossary type `main' has not been defined.

See the glossaries package documentation for explanation.
Type  H <return>  for immediate help.
 ...                                              

l.1 ...{o}rster distance, where 50\% ...}, sort=R}

? H
You need to define a new glossary type, before making entries in it

What should I do? I'm searching similar topics, for example, here. However, I haven't understood how this topic is related to me.

I hope you will help me:)

1

1 Answer 1

2

Remove nomain from the options you pass the package. If you use this, you have to define specific glossaries and assign entries to them - there is no default glossary, main. If you remove the option, everything will be added to the default glossary unless otherwise specified, which seems to be what you want.

1
  • Okay, I've corrected it. But I have an error when makeglossaries main: xindy -L russian -C utf8 -I xindy -M "main" -t "main.alg" -o "main.acr" "main.acn" Opening logfile "main.alg" ERROR: Opening logfile "main.alg" failed! Call to xindy failed May 28, 2015 at 2:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .