0

I have decided to change font and heard about the fourier package. I thought I just had to type \usepackage{fourier} for it to work but the text then completely disappeared. Here is the document preamble

\documentclass[10pt,a4paper,titlepage]{report}
\usepackage[latin1]{inputenc}
\usepackage{fourier}
\usepackage{amsmath}
\usepackage{graphicx}
\usepackage{amsfonts}
\usepackage{amssymb}
\usepackage{cancel}
\usepackage{tikz}
\usepackage{marginnote}
\usepackage{MnSymbol}
\usepackage[vscale=0.82, vmarginratio=1:1, hscale=0.8,  
hmarginratio=1:1,   headsep=15pt, footskip=20pt]{geometry}

I'm sorry if the question is stupid, I just have no clue how latex works, are there now two font package?

More info When I compile I can see

Trying to make PK font futri8r at 552 DPI...
Running miktex-makemf.exe...
miktex-makemf: The futri8r source file could not be found. Running ttf2pk.exe..
miktex-makepk: PK font futri8r could not be created
  • I can't reproduce the issue. Do you get any error message? – egreg May 28 '15 at 16:53
  • oh, i forgot some more packages, I add it right away – Noix07 May 28 '15 at 17:07
  • You have a faulty installation: the fonts are not enabled in the map file. – egreg May 28 '15 at 17:39
  • What do I have to install? Miktex again? – Noix07 May 28 '15 at 17:40
  • 1
    You just have to run from the command line (both as administrator and as user): \updmap.exe. – Bernard May 28 '15 at 18:24
2

What MiKTeX often doesn't do is this: after installing a font and the packages required to use it, the type 1 fonts database has to be updated. The reason is essentially that LaTeX uses conventioal font names and a system of metric files to compose the document, then dvips or pdflatex have to know where the real fonts are to be found. This is stored in several fikes named psfonts.map and the like.

When you install a new font these files have to be updated, which MiKTeX doesn't always do, so you have to do it on your own with the command line: updmap.exe, both as administrator and as user.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.