I have a document where I want to create links from my table of contents, citations and references, in an ordinary way. My first line is


and CUNY_PhD is a custom .cls file provided by my school. When I insert


into the preamble, there is no error message, but it has no effect on the document. If I do this in a test document, it works fine. Do I need to learn how to further customize the .cls?

1 Answer 1


I figured this out actually while posting the question, but figured I'd post it, plus this answer, anyway, since I couldn't find the answer by searching.

All I had to do was take out "draft" from the documentclass options!

  • 7
    you can also force hyperref while keeping draft for the rest of the document by passing the option final to hyperref alone: \usepackage[final]{hyperref}
    – ArTourter
    May 28, 2015 at 21:49
  • That is an even better solution, since I want to alter this template as little as possible in achieving my linkage.
    – j0equ1nn
    May 28, 2015 at 22:32
  • I didn't have the draft option in the document class still it is not working for me. Also, when I use the [final] option with \usepackage{hyperref} I get the following error: ! LaTeX Error: Option clash for package hyperref.
    – PHcoDer
    Aug 22, 2021 at 13:49
  • I also have tried both recommendations. Still broke Dec 5, 2022 at 20:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .