5

I've been working on my thesis with MikTex, and I've had a problem for some time now. Every Ä and Ö letter is marked a black box of sort or as ?. I've looked around the internet and I know that you need to have

\usepackage[ansinew]{inputenc}

before you start writing. However when I try to use that, it gives me this error:

! LaTeX Error: Command \textcurrency unavailable in encoding T1.

I'm using my university's template for the thesis, which has all the settings premade. For example:

\documentclass[a4paper, 12pt]{article}
\usepackage[T1]{fontenc}
\usepackage{setspace}
\usepackage[dvips]{epsfig}

are all set. Any clue or idea what is wrong?

Thank you.

edit:

\documentclass[a4paper, 12pt]{article}
\usepackage[T1]{fontenc}
\usepackage{setspace}
\usepackage[dvips]{epsfig}



% ====== ASETETTAVIA PARAMETREJA / ALKAA ==========================


% ----------- K?ytt?j?rjestelm?st? riippuvat:


% UNIX:ia k?ytett?ess?:

% \usepackage[latin1]{inputenc}


% DOS-ymp?rist?ss?:

% \usepackage[cp850]{inputenc}


% Windows-ymp?rist?ss?:

\usepackage[ansinew]{inputenc}

% K?ytett?v?t makropakkaukset:

\usepackage[finnish]{babel} % Kieli: Suomi
\usepackage{times}      % Kirjasin: Roman Times
\usepackage[dvips]{graphics}    % Postscript-kuvat kelpaavat

\usepackage[]{vmargin}      % Tarkempi marginaalien asettelu
\usepackage{url}        % Oikea tavutus URLeihin
\usepackage[]{longtable}    % Kun taulukko on pitk?

% Kappaleiden ulkoasu:

\setlength{\parindent}{0pt}
\setlength{\parskip}{2ex}
\linespread{1.3}
\sloppy


\setpapersize{A4}       % Paperikoon valinta ja
%                      Tarkka marginaalien asetus vmargin paketilla
\setmarginsrb{35mm}{30mm}{30mm}{20mm}{0pt}{0mm}{12pt}{13mm}

\begin{document}

% ----------------- Tiivistelm? ------------------------------

% 150-200 sanaa pitk? tiivistelm?, jonka tulee mahtua yhdelle
% sivulle

Ohjelmistotuotanto pitää sisällään monen tyyppisiä ihmisiä. Ihmisillä on erilaiset persoonallisuustyypit, joita voidaan saada selville muun muassa MBTI:n avulla. MBTI:llä selvitetään, millaisia persoonallisuuspiirteitä ihmisellä on. Nämä piirteet voidaan jakaa neljään osaan: energisyys, tiedon saanti, päät?ksen teko sekä elämäntyyli. Ohjelmistotuotanto vetää puoleensa sellaisia ihmisiä, joiden persoonallisuustyyppi on sopiva kyseiselle alalle. Erityisesti ajatteluun perustuvat päätöksen tekijät ovat yleisiä yksilöitä ohjelmistotuotannossa, kun taas näiden vastakohdat ilmenevät ohjelmistotuotannossa harvemmin. Tietyn persoonallisuustyypin ihmiset sijoittuvat useimmiten tietynlaisille aloille ja työtehtäviin. Myös eri persoonallisuuspiirteet voivat joko heikentää tai parantaa sopivuutta tietynlaiseen työtehtävään. Tästä huolimatta, ohjelmistotuotanto vaatii monia erilaisia persoonallisuuspiirteitä omaavia henkilöitä työryhmiin, sillä eri näkökulmat ja monipuolisuus parantavat ohjelmiston laatua.

\end{document}
  • 1
    Welcome to TeX.SX! You should provide us with more information. epsfig is really, really outdated. And as a German I would say, that Ä,Ö,Ü are not restricted to Scandinavian languages ;-) – user31729 May 29 '15 at 7:58
  • 1
    The encoding you select for inputenc depends on which encoding your editor uses, they should match. TeXworks for example, which is included in MikTeX, uses utf8 as the default encoding (IIRC). – Torbjørn T. May 29 '15 at 8:01
  • Have you tried setting the file manually to a different encoding (eg. Unicode)? I had a similar problem with cyrillic characters compiled with XeLaTeX, and fixed it by changing the default file encoding to unicode. I'm using Windows though, so I'm not sure how relevant this is if you're a Linux user. – blaze May 29 '15 at 8:34
  • I'm using Windows as well. Could you explain how to set file manually to different encoding? – Gettingtiredofthis May 29 '15 at 8:36
5

The fact that this compiles to me means that there's something more going on. If you have your editor configured to use utf8 this works perfectly.

\documentclass{scrartcl}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage[finnish]{babel} % Kieli: Suomi

\begin{document}

Ohjelmistotuotanto pitää sisällään monen tyyppisiä ihmisiä. Ihmisillä on
erilaiset persoonallisuustyypit, joita voidaan saada selville muun muassa
MBTI:n avulla. MBTI:llä selvitetään, millaisia persoonallisuuspiirteitä
ihmisellä on. Nämä piirteet voidaan jakaa neljään osaan: energisyys, tiedon
saanti, päät?ksen teko sekä elämäntyyli. Ohjelmistotuotanto vetää puoleensa
sellaisia ihmisiä, joiden persoonallisuustyyppi on sopiva kyseiselle
alalle. Erityisesti ajatteluun perustuvat päätöksen tekijät ovat yleisiä
yksilöitä ohjelmistotuotannossa, kun taas näiden vastakohdat ilmenevät
ohjelmistotuotannossa harvemmin. Tietyn persoonallisuustyypin ihmiset
sijoittuvat useimmiten tietynlaisille aloille ja työtehtäviin. Myös eri
persoonallisuuspiirteet voivat joko heikentää tai parantaa sopivuutta
tietynlaiseen työtehtävään. Tästä huolimatta, ohjelmistotuotanto vaatii
monia erilaisia persoonallisuuspiirteitä omaavia henkilöitä työryhmiin,
sillä eri näkökulmat ja monipuolisuus parantavat ohjelmiston laatua.

\end{document}
  • Wait a moment...Now if I changed it to \usepackage[utf8]{inputenc} and checked the first section (where I retyped all ä's and ö's) it shows them properly! I just have to retype every ä and ö letter now I guess? Will see if it works. – Gettingtiredofthis May 29 '15 at 9:43
  • Yes, it does work now. I just have to retype every single ä and ö letter. But in all honesty, I'll gladly do that if it now works. Thank you so much for the help everyone. This has been bugging me so much while trying to work on the thesis. – Gettingtiredofthis May 29 '15 at 9:50
  • 1
    Don't, just use find and replace, copy an ä and replace with a letter ä written by you (it seems silly, but the same happens if you compile, copy from the pdf and recompile). – Manuel May 29 '15 at 9:59
  • @Gettingtiredofthis: Looks like your file contains a mix of UTF-8 and some other text encoding (most likely ISO-8859-1 or -15). There are tools to fix such messes (like, say, the Encoding::FixLatin Perl module), but if your editor is showing both of them correctly, you may find that simply copy-pasting the text into another program (say, the Stack Exchange editor) and back again will fix it. – Ilmari Karonen May 29 '15 at 19:48
5

The letter, which causes the error message

! LaTeX Error: Command \textcurrency unavailable in encoding T1.

is neither Ä nor Ö but ä:

\documentclass{article}
\usepackage[T1]{fontenc}
\usepackage[ansinew]{inputenc}

\begin{document}
Ä Ö ä ö
\end{document}

And the output something like this

Result

The reason is, that your input file is not encoded in ansinew, but UTF-8. If you want to continue with UTF-8, then use

\usepackage[utf8]{inputenc}

For an automatic encoding detection, see package selinput.

  • 1
    Like i said, utf8 doesn't work either. edit: apologies, didn't answer this post that I've tried utf8. :) – Gettingtiredofthis May 29 '15 at 8:12
  • @Gettingtiredofthis What's the result of using selinput? – Heiko Oberdiek May 29 '15 at 8:21
  • Not sure if I used it correctly. I just wrote: \usepackage{selinput} \SelectInputMappings{ adieresis={ä}, } and it still gives the same error: ! Package inputenc Error: Unicode char \u8:� not set up for use with LaTeX. – Gettingtiredofthis May 29 '15 at 8:24
  • @Gettingtiredofthis Then your input is UTF-8. The error message is a complete different error, maybe even unrelated to Scandinavian letters. For example, it can be caused by an non-break characters (fixed by \DeclareUnicodeCharacter{A0}{ } or \DeclareUnicodeCharacter{A0}{~}). Try to identify the problematic line and character. The error message shows the error line and a hex viewer might help in finding the problematic characters. – Heiko Oberdiek May 29 '15 at 8:31
  • 1
    @Gettingtiredofthis If I had your file, then I could check line 196. – Heiko Oberdiek May 29 '15 at 8:58
3

For the \textcurrency thing (it looks like a sputnik: ¤) you also need the package

\usepackage{textcomp}

in addition to the already mentioned packages

\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc} % or \usepackage[latin1]{inputenc} when using 8bit encoding

EDIT: Addendum: From the conversation I oversee that your encoding might be messed up (utf8 reinterpreted as latin1 or Windows encoding). This situation is known as "mojibake" and there is a python codec to fix this on PyPI here: https://pypi.python.org/pypi/mysql-latin1-codec/2.0

2

This works for me under Emacs/Linux with utf8 encoding. If ansinew does not work for you, then utf8 is perhaps the correct option. If the editor uses a different encoding this most be specified. I can't test ansinew, since none of my editors on Linux support this (or I just don't know how to change it) and I don't use Windows.

\documentclass[a4paper, 12pt]{article}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage{setspace}

\begin{document}

Der schnelle braune  Fuchs springt über den faulen Hund

Äpfel -- apples

Öl    -- oil


\end{document}

enter image description here

  • I've tried utf8 instead of ansinew. – Gettingtiredofthis May 29 '15 at 8:07
  • @Gettingtiredofthis: And what was the result? – user31729 May 29 '15 at 8:08
  • ! Package inputenc Error: Unicode char \u8:� not set up for use with LaTeX. – Gettingtiredofthis May 29 '15 at 8:09
  • @Gettingtiredofthis: Well, in this case, I assume, there is even more issue in your document – user31729 May 29 '15 at 8:11
  • You might want to have a look at my answer to inputenc Error: Unicode char \u8: not set up for use with LaTeX -- the � looks like a generic failure/substitute symbol. – Chris H May 29 '15 at 13:02
1

You can also produce umlauts without any additional packages by using the control sequence \". For example Universit\"at for 'Universität'.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.