2

In Tufte-LaTeX, the standard behavior of the \cite command is to put the reference in the sidenotes area (see example at https://github.com/Tufte-LaTeX/tufte-latex/blob/master/sample-handout.pdf). Additionally, they will appear in the bibliography.

I want to have the standard citation behavior without the reference appearing in the sitenotes.

I've messed around with the tufte-common.def file, but could not get the desired effect. Can anybody give me a hint on how to achieve this?

  • Use the nobib option: \documentclass[nobib]{tufte-book}. Then you can \usepackage{natbib} or \usepackage{biblatex} or whatever you like. – godbyk May 29 '15 at 15:26
  • @godbyk: Nope, that doesn't work. It's still in the margins. Besides that, the compiler complains about \bibhang already defined – user31729 May 29 '15 at 15:37
  • @ChristianHupfer For me it works as intended, both in my own project as well as in the minimal example provided by you. – Paul Klemm May 29 '15 at 15:50
  • @godbyk Please provide the comment as answer so I can close this question. – Paul Klemm May 29 '15 at 15:53
  • @PaulKlemm: The nobib option is not documented in the manual. Apparently, I've missing some knowledge here, so its better to delete my answer – user31729 May 29 '15 at 15:57
2

To disable Tufte-LaTeX's handling of citations, you can pass the nobib option to the document class:

\documentclass[nobib]{tufte-handout}% or tufte-book

You would then need to load the natbib, biblatex, or other bibliography package yourself with, e.g., \usepackage{natbib}.

The \cite command will behave the same as it does for the article or book document class.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.