2

Trying to embed a .avi in a Beamer presentation using the multimedia package and I can't figure out where I went wrong. Using Windows 7 and Adobe Reader to view the presentation, and TeXworks to write the presentation.

MWE:

\documentclass{beamer}

\mode<presentation> {\usetheme{Madrid}}

\usepackage{graphicx}
\usepackage{multimedia}

\begin{document}

\begin{frame}
\frametitle{Title}
\movie[poster]{}{MCMCMovie.avi}
\end{frame}

\end{document}

MCMCMovie.avi is at https://www.dropbox.com/s/ov5rz591yp35kxd/IMG_3746.avi?dl=0

Presentation just shows one blank slide, using either Adobe Reader or teXworks.

What am I missing?

  • Wrong video codec? Note that AVI is only a container format. Try the media9 package which embeds h.264 (MP4) video. – AlexG May 30 '15 at 8:55
1

It looks like you just need to include the dimensions that you want your video to be: \movie[width=9cm,height=7cm, poster]{}{movie.avi}. I used your code and simply added those and things work great. Of course, this media package does not embed the video into the pdf, so you will need to still keep the video in the directory of the pdf for it to play.

\documentclass{beamer}

\mode<presentation> {\usetheme{Madrid}}

\usepackage{graphicx}
\usepackage{multimedia}

\begin{document}

    \begin{frame}
        \centering
        \frametitle{Title}
        \movie[width=9cm,height=7cm, poster]{}{movie.avi}
    \end{frame}

\end{document}

And on windows, Adobe Reader often complains about embedded files as a security risk, so you have to trust the document to enable the video: Adobe Reader security prompt

After which, it should look similar to this: Playing video in Adobe Reader

Note: If you do not like the generic video symbol, you can use words or images as a placeholder for your video by filling in the first set of curly braces with the text or includegraphics command

  • Sorry but doesn't work here. The example video uses the "MJPEG" codec and renders as a black rectangle here. Note that the method chosen by multimedia depends on third-party plug-ins during viewing time, which may not be available. – AlexG Jun 1 '15 at 9:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.