1

In a document using the classicalthesis package, in order to get footnotes without links (*) (but leave the links everywhere else), I tried all the options I could find: using \hypersetup with hyperfootnotes=false, loading hyperref again (it is loaded automatically by classicalthesis) with the same option (**), changing the order of the loads in all possible ways, ... nothing worked: the darn footnotes were still links.

I tried to generate a MEW, but to no avail: the only way to get linkless footnotes was to comment out the line using the package. So I looked at classicalthesis' source code, and modified it by adding [hyperfootnotes=false] on the two places where hyperref is loaded:

    % ********************************************************************                
    % PDF and XeLaTeX Stuff
    % ********************************************************************
    \RequirePackage{ifpdf}
    \ifpdf\RequirePackage[hyperfootnotes=false]{hyperref}\fi % for texorpdfstring command below

    % Necessary to rewrite hacks for chapters and parts and toc
    \RequirePackage{ifxetex}
    \ifxetex\RequirePackage[hyperfootnotes=false]{hyperref}\fi % for texorpdfstring command below

    % pdfspacing does not work with XeLaTeX
    \ifxetex%
        \ifthenelse{\boolean{@pdfspacing}}%
                {% pdfspacing is used with XeLaTeX
                        \PackageWarningNoLine{classicthesis}{You cannot use the option %
                        "pdfspacing" with XeLaTeX!}%
                }{\relax}%
        \setboolean{@pdfspacing}{false}%
    \fi

This did the trick! But my question is: is there a simpler way? Preferably one that does not involve modifying any package's source code?

(*) - The reason I wanted this in the first place was because the links of the footnotes were wrong, and when trying to correct them, I discovered that even hyperref's developer admitted that the linked footnotes were a brittle functionality... So I gave it up altogether.

(**) - This threw an error complaining the hyperref was being (re)loaded with incompatible options...

4

Pass the option to the package.

wmnorthClassicthesisHyperfootnote

\documentclass[headinclude=true,footinclude=true]{scrreprt}
\PassOptionsToPackage{hyperfootnotes=false}{hyperref}
\usepackage{classicthesis}
\setlength{\textheight}{3cm}
\begin{document}
Pogo penguin\footnote{this is not a lazy leguan}
\end{document}
|improve this answer|||||
  • 1
    I had actually tried adding that very line, but I had added it after the \usepackage... With hindsight, it's pretty darn obvious that it had to go before... thanks for pointing it out! – wmnorth May 29 '15 at 21:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.