I am using hyperlinks in a latex text (specifically with hyperref and cleveref). Usually I read pdf at a zoom >100% to eliminate white borders from the displayed part; but when I click on a hyperlink the alignments gets messed up as the redirect tries to place the linked element on the leftmost side of the page. This is particularly annoying when I click at an equation hyperlink, as I keep the numbering on the rightmost side of the page.

How can I suppress the vertical re-alignment when clicking on a link?

If you want to try it yourself, here's a MWE:





In https://www.tug.org/applications/hyperref/manual.html I have found the option pdfview which should do the job. It is stated that it takes three values XYZ which respectively indicate the position (left, top) and the zoom at which the links should work. However I'm unable to use them as

\usepackage[pdfview={XYZ 12 123 1234}]{hyperref}

doesn't do anything... How should I pass the value to pdfview?

  • Welcome to TeX.SX! Please help us to help you and add a minimal working example (MWE) that illustrates your problem. It will be much easier for us to reproduce your situation and find out what the issue is when we see compilable code, starting with \documentclass{...} and ending with \end{document}. – user31729 May 31 '15 at 16:59
  • i believe this is a function of the pdf reader, and that it can't be controlled from within latex. (i would be very happy to be proved wrong!) – barbara beeton May 31 '15 at 17:09
  • @barbarabeeton in that case, could i place the mark to which the link points on the leftmost side of the page? – Quoniam May 31 '15 at 17:22
  • @Quoniam -- specifying the option \usepackage[leqno]{amsmath} will place the equation numbers on the left side of the page. – barbara beeton May 31 '15 at 17:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.