0

I have an issue related to texmakers internal viewer (at least I think, thats were the problem is comming from).

Here is a minimal working example and the link to the file Issue.pdf

\documentclass[10pt,a4paper]{article}
\usepackage[utf8]{inputenc}
\usepackage{graphicx}

\begin{document}

Issue file

\begin{center}
\includegraphics[scale=0.7]{Issue}
\end{center}

\end{document}

When I compile the above code in texmaker everything is fine but when I look at the pdf using the internal pdf viewer the points on the graphic are not shown .

Strangely, when I look at the compiled pdf using an external pdf viewer (Adobe Acrobat, SumatraPDF) the points are back as they should.

Another odd thing is that any other graphical element is displayed as it should (lines, bar, colours etc.)... just the points are missing.

Here is a number of things I already did:

  • I updated all the software involed: I have the newest version of texmaker (4.4.1) the newest version of R, RStudio (these were used to create the graphic "Issue.pdf").
  • It is apparently not an issue with RStudio or ggplot2, since I have the same behaviour when plotting a simple scatterplot using the base R function plot().
  • I tried to run the above code on another computer with the same result.
  • Reinstalled Texmaker (no change).

If you have any suggestions or hints as to what might cause the issue I'd be much obliged.

Note: The issue came up because I reinstalled my computer. Any old .tex-file that had graphics with dots/points in it that had worked before suddently doesnt work anymore.

  • Each different pdf viewer in combination with the operating system and the hardware often will work differently (resolution, scan rates, pixel size, interpolation algorithms). Additionally you can have differences in the printing results. However, a useful solution is to choose the appropriate viewer and printer which is best for your specific applications. In general, the acrobat reader (or Pro) is usually the most correct. One suggestion, have you tried the internal viewer in the detached mode running full screen. – R. Schumacher Jun 2 '15 at 15:47
  • Yes its the same. I am pretty certain that it is an issue related to the internal viewer. However the question remains: why ? Interestingly, two of my collegues have exactly the same issue. What we have in common, is that we are using the newest version of texmaker.... I wonder if this issue does not appears in older versions, in which case it would be a bug. – Manuel R Jun 2 '15 at 17:55
  • Recommend you report this to code.google.com/p/texmaker/issues/list Provide a working example which shows the problem. – R. Schumacher Jun 2 '15 at 18:53
  • Done! see (code.google.com/p/texmaker/issues/…) – Manuel R Jun 2 '15 at 19:25
  • Was this solved? I have very similar problem, my TexMaker pdfviewer does not show some greek letters and minus signs in included graphics. – Suzie Jan 11 '18 at 11:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.