5

I'm trying to pu my beamer TOC on two columns and I have this problem. When I divide my page in two equal columns, the left column is vertically misaligned.

\begin{frame}[plain]
\frametitle{Le Langage}
\begin{columns}[t]%
\begin{column}{.45\linewidth}%
\tableofcontents[part=1,sections=<1-2>]%
\end{column}%
\begin{column}{.45\linewidth}%
\tableofcontents[part=1,sections=<3-4>]%
\end{column}%
\end{columns}%
\end{frame}

enter image description here

But when I give a wider column at left, (When there is no line return) the columns are vertically aligned as I want.

\begin{frame}[plain]
\frametitle{Le Langage}
\begin{columns}[t]%
\begin{column}{.4\linewidth}%
\tableofcontents[part=1,sections=<1-2>]%
\end{column}%
\begin{column}{.6\linewidth}%
\tableofcontents[part=1,sections=<3-4>]%
\end{column}%
\end{columns}%
\end{frame}

enter image description here

Do you know how to give my columns the same width and the correct vertical alignment ?

  • 1
    Try giving the option [T] instead of [t] to {columns}. – Herr K. Jun 2 '15 at 21:30
  • It's working well with option [T] – JeanJouX Jun 2 '15 at 22:21
  • @HerrK. Would you like to write up an answer? – Torbjørn T. Oct 1 '15 at 14:53
2

I cannot reproduce the problem without an MWE. But it seems that giving the option [T] instead of [t] to the {columns} environment would solve the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.