4

I have a conflicting options error message, and I can't figure out what is causing it. Please see my set-up below. I realise this a pretty complex set-up, so I'm not looking for a full analysis of it; just hoping that someone might be able to spot something simple that I've missed, with just a quick read. Many thanks in advance.

The error message (the line number is sadly not helpful...):

example.tex:0 Conflicting options.

My document header:

\documentclass{article}
\usepackage{graphicx, epsfig, subfig, setspace, fixltx2e, amsmath, textcomp, gensymb, csquotes, floatrow, siunitx, xpatch, nomencl, rotating, fullpage, appendix, epstopdf}
\usepackage[version=3]{mhchem}
\usepackage[british]{babel}
\usepackage[labelfont=bf]{caption}
\usepackage[style=authoryear-comp, punctfont, sorting=nyt, sortcites=noneyear, eprint=false, firstinits=true, doi=false, url=false, isbn=false, backend=biber, maxbibnames=99, maxcitenames=2, uniquelist=false]{biblatex}
\addbibresource{biblatex-examples.bib}
\AtEveryBibitem{\clearfield{issn}}
\AtEveryBibitem{\clearfield{note}}
\AtEveryBibitem{\clearfield{number}}
\AtEveryBibitem{\clearfield{language}}
\AtEveryBibitem{\clearfield{Language}}
\DeclareFieldFormat{postnote}{#1}% no postnote prefix in "normal" citation commands
\DeclareFieldFormat{multipostnote}{#1}% no postnote prefix in "multicite" commands
\DeclareFieldFormat{pages}{#1}% no prefix for the `pages` field in the bibliography
\DeclareFieldFormat
  [article,inbook,incollection,inproceedings,patent,thesis,unpublished]
  {title}{#1\isdot}
\DeclareFieldFormat*{volume}{\mkbibbold{#1}}%make volume number bold in the bibliography
\renewbibmacro{in:}{}

\DeclareFieldFormat{author}{#1\addcomma\space}
\let\oldmultinamedelim\multinamedelim
\let\oldfinalnamedelim\finalnamedelim
\renewcommand*{\multinamedelim}{\space\bibstring{and}\space}

\AtBeginBibliography{
  \renewcommand*{\multinamedelim}{\oldmultinamedelim}
  \renewcommand*{\finalnamedelim}{\oldfinalnamedelim}
}
\renewcommand*{\nameyeardelim}{\addcomma\addspace}
\DeclareSortingScheme{noneyear}{
 \sort{\citeorder}
 \sort{\field{year}}
}
\DeclareFieldFormat[book]{title}{#1}

\DeclareFloatFont{footnotesize}{\footnotesize}
\floatsetup[table]{font=footnotesize}
\floatsetup[table, figure]{\centering}
\floatsetup[table]{style=plaintop}

\makenomenclature
\renewcommand{\nomname}{Abbreviations}
\newcommand*{\nom}[2]{#1\nomenclature{#1}{#2}}

\newcommand{\superscript}[1]{\ensuremath{^{\textrm{#1}}}}
\newcommand{\subscript}[1]{\ensuremath{_{\textrm{#1}}}}

\usepackage{fancyvrb}
\DefineVerbatimEnvironment{code}{Verbatim}{fontsize=\small}
\DefineVerbatimEnvironment{example}{Verbatim}{fontsize=\small}
\begin{document}
1
  • Thank you for posting a working example! At the same time, much of your code does not seem to be relevant to the question you're asking here. Please limit the example to only the code required for your issue to appear. You can have a look at this guide for how to prune your code for this purpose. Jun 6, 2015 at 16:39

1 Answer 1

4

The full error message is

Package biblatex Warning: Conflicting options.
(biblatex)                'firstinits' conflicts with 'uniquename=full'.
(biblatex)                Setting 'uniquename=init' on input line 62.

see the output or .log file. So it is coming from biblatex and is not a fatal error. The style is setting the uniquename option, so I suggest you add uniquename=init to the options you pass to biblatex

1
  • Perfect, that did the trick. Thank-you very much. Jun 6, 2015 at 16:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.