I just installed Excel2LaTeX in Excel 2010.

I do see it in add-ins. However, I cannot find a way to operate it. That is, there is no change in the ribbon area after the package was installed.

How does one use the package?

  • Welcome to TeX.sx! You don't have to sign with your name since it automatically appears in the lower right corner of your post. Aug 4, 2011 at 15:35
  • 1
    This is really off-topic here, since your problem is with Excel and an add-in, and not with TeX itself.
    – Alan Munn
    Aug 4, 2011 at 15:36
  • 7
    @Alan: Conversion tools are usually on-topic.
    – Caramdir
    Aug 4, 2011 at 16:06
  • 2
    I second Caramdir: "If you have a question about [...] (La)TeX related software and tools like BibTeX, LyX, LaTeX editors, viewers, and converters ... then you're in the right place to ask your question!" (FAQ)
    – doncherry
    Aug 4, 2011 at 17:27
  • It does NOT work in Excel 2011 for Mac. For 2010 and 2007 I had to restart to see the ribbon. Microsoft is hopeless. Oct 4, 2011 at 2:11

4 Answers 4


After an add-in has been installed, it is available to use, but it has to be activated first. For this, follow these instructions. An abbreviated list of steps are:

  1. Click the Microsoft Office Button.
  2. Click Excel Options.
  3. Click Add-Ins.
  4. Note the Add-in Type in the list displayed.
  5. Select the Add-in Type in the manage box and click Go.
  6. Select [clear] the check box for the Add-in that you want enable [disable] and then click OK.

Specifically for the Excel2LaTeX add-in for Excel, after downloading it and reaching step 5 above, this is how I installed it on my computer:

  • Locating the Excel2LaTeX add-in by clicking on the Browse button:

Locating the Excel2LaTeX add-in

  • Activating the Excel2LaTeX add-in by selecting it from the add-in menu:

Activating the Excel2LaTeX add-in

  • New add-in menu showing the "Convert to LaTeX table" button in Excel:

New add-in menu showing the "Convert to LaTeX table" button in Excel

Note that any add-in is specific to the location that it is stored in, since the code/macros are stored in a file rather than being "installed" under your traditional "Program Files" folder. So, it would be preferable to put it in a recognizable folder that you can find and access later. That is, avoid putting it in something like C:\Temp\ where it may be easily erased.

  • 1
    I did activate it. However, there is no new buttom that allows me to copy a table into LaTex.
    – Slava
    Aug 4, 2011 at 16:58
  • 1
    @Slava: I've updated my answer to show what I did to get it installed on my computer. I did this in Excel 2007. However, the CTAN link I provided suggests v3.1 (as of May 19, 2011) of the Add-in works for Excel 2007+. Perhaps you have an older version that may not be compatible.
    – Werner
    Aug 4, 2011 at 18:19
  • 1
    after restarting excel, the button should be there. Thankts for the instructions, for me it works!
    – user8701
    Oct 19, 2011 at 12:38
  • Will the add-on also extract the graphs from the excel file or only data?
    – Jeel Shah
    Mar 12, 2013 at 0:33

Use this online version instead! No installation necessary.



I'm using Excel 2013 and did initially not manage to get Excel2LaTeX to show in add-ins, it seems to work for some people and not for others using the same version of Excel. What worked for me was to disable all other add-ins that were listed before Excel2LaTeX . When I did that Excel2LaTeX showed upp in add-ins and works! Try disabling other add-Ins


Although, the question is for Excel 2010, I think Excel 2020 is also relevant here.

I have to do 2 extra steps to make it working in excel 2020.

  1. Unblock the xla file by going to properties and check the unblock as highlighted in the picture.

enter image description here

  1. After unblocking open the file and try to run excel2latex functions by going to Add in tab. A pop up will appear asking to allow macros. Allow them and everything will work.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .