3

I use Lyx editor for a document that has a lot of high-res plots (maybe I could downscale the images, but that's not the point), these images are too large when rendered in LyX GUI, for example they look like that (screenshot from full HD monitor):

Example of lyx layout.

Which makes editing the figures cumbersome.

Is there any way to:

  • Downscale image files rendered in LyX GUI (produced pdf files should contain full resolution files.
  • Hide image files altogether from LyX GUI.

I would like to change these settings on document level, I'm aware that I can downscale (or hide) every graphic separately, but as I have many figres (all high-res) I'd rather do it in a single place.

This looks like a basic problem, but I couldn't find anything by browsing the preferences nor by googling.

I use LyX 2.1.1 (but can upgrade if neccessary).

  • If downscaling could be a solution, maybe using LyX's "Graphics Group" could be a solution? (see the graphics settings option under "LaTeX and LyX options"). Another possible workaround would be to edit the converter that LyX uses to convert to the onscreen display. For example, for the PDF -> EPS converter, mine uses pdftops. There is probably an option to pdftops that could help. – scottkosty Jun 8 '15 at 15:56
3

Three options:

A) If the image is inside a float (as show in your picture), or a note, or a a brach, etc., the you can close the box. How to:

  1. Just left-click on the box label.
  2. Same as above: right-click on the label box and then select Close box (or something like that, sorry, I am translating from the Spanish version).
  3. Menu View > Close all boxes

B) Scale down the image in the screen. The source image is not modified and the resolution in the PDF is maintained, as show the picture:

MWe

How to:

  1. With Insert > Image ... > LaTeX and LyX options > Scale in the screen (%)
  2. Left-click on the image > LaTeX and LyX options > Scale in the screen (%)
  3. Right-click on the image > Configuration... > LaTeX and LyX options > Scale in the screen (%)

C) Draft mode.

  1. For individual images. Open again theirConfiguration... menu.
  2. For the whole document: Menu Tools > Preferences > Appearance > Visualization > Uncheck "Show graphics" > Apply
  • Closing the box is a solution, but when I'm workin on 2 x 2 subfigure it ends up a mess. Is there any way to set default "Scale in the screen" for new figures. – jb. Jun 8 '15 at 19:36
  • @jb No as far I know, but see the updated answer for another default view. – Fran Jun 8 '15 at 21:21
  • Third option works for me! – jb. Jun 10 '15 at 9:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.