5

Is there a way to automatically update the file path of where my references are stored? I keep them in a folder "References". This is the full path to my references:

\addbibresource{C:/Users/bossman/Desktop/Document/References/chap1.bib}
\addbibresource{C:/Users/bossman/Desktop/Document/References/chap2.bib}
\addbibresource{C:/Users/bossman/Desktop/Document/References/chap3.bib}
\addbibresource{C:/Users/bossman/Desktop/Document/References/chap4.bib}

The main folder "Document" is where all my tex and other related files are stored. If I move the Document folder now to let's say F:/LatexFiles, or even another computer, my \addbibresource complains and I have to go and update the path now manually. Is it possible to automate this filepath name?

Here is a screen shot of my folder structure. The References folder is where my .bib files are in:

enter image description here

and here is the References folder with my chap.bib files:

enter image description here

  • 2
    With TeX Live (even on Windows?) you have the BIBINPUTS variable, to which you could add your "personal" locations. But I don't really know Windows, and I really don't know MiKTeX (if you are using that).... – jon Jun 9 '15 at 1:09
  • I am using MiKTeX and Windows 7. – Joe Jun 9 '15 at 3:49
  • 1
    What about relative paths? That is \addbibresource{./References/chap4.bib} and the like. – moewe Jun 9 '15 at 4:59
  • I get the error Cannot find './References/chap4.bib'! – Joe Jun 9 '15 at 6:00
  • 1
    Relative pathes as suggested by moewe should work if your bib-files are really in a subfolder of your tex document and if you are starting biber from the folder of the tex document. – Ulrike Fischer Jun 9 '15 at 9:41
7

UPDATE

In WinEdt 9.1 build 20150713 the bug described below has been solved.

Simply use

\addbibresource{References/chap1.bib}
\addbibresource{References/chap2.bib}
\addbibresource{References/chap3.bib}
\addbibresource{References/chap4.bib}

and biber will compile your bibliographies correctly.


ORIGINAL ANSWER

The correct way is to use

\addbibresource{References/chap1.bib}
\addbibresource{References/chap2.bib}
\addbibresource{References/chap3.bib}
\addbibresource{References/chap4.bib}

But you are using WinEdt 9 and there is a bug in the compiler script for BibTeX and biber which prevents biber to run successfully when you redirect your auxiliary files to another folder.

To circumvent this (it will be fixed in the next release of WinEdt), open the file BibTeX.edt (it should be somewhere like C:\Program Files\WinEdt 9\Exec\TeX), then open the Options Interface and click on "Advanced Configuration".

Now click on the button "Create and Open Local Copy". A modifiable local copy of BibTeX.edt gets opened.

enter image description here

Just after the line

  IfIStr("%$('%!9-Executable');","bibtex.exe","<>",!"LetReg(3);");

insert the lines

  IfIStr("%$('%!9-Executable');","biber.exe","=",>
    !|IfStr('%O','%P','<>',!`LetReg(3,'--input-directory "%P"');`);|);

Now save the file and the job is done.

Try recompiling your file and now WinEdt correctly runs biber on your bibliographies.

1

@moewe gave the solution where the path had to include double periods...i.e., the path would now be

addbibresource{../References/chap1.bib}

.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.