7

In my ḍād package (for Arabic typesetting, see also the TUGboat paper) I use a PostScript font with OFM metrics file. I load the font in the usual way, going through an FD file. This works only for luaLaTeX, since the latter is the only OFM-compatible TeX offspring (thanks to its Omega genes).

My ḍād font is not loaded anymore when I include the fontspec package. As you can see if you visit this overleaf page, as soon as the fontspec package is loaded, the OFM-PFB font dad cannot be found anymore. This means that a user of ḍād cannot use TrueType fonts in luaLaTeX (at least not going through fontspec, which is the most practical way), and this is quite a pity.

Does someone know how to load a PFB font with OFM metrics in a fontspec-compatible way?

1 Answer 1

4

Hmm not really the user interface you want, but perhaps a pointer to a solution, the document runs without error (and I hope makes the right thing, although I can't read it:( if you force the font to be loaded before fontspec triggers (I assume) luaotfload which changes the font loading

\documentclass{article}
%\usepackage[utf8]{inputenc}

\usepackage{dad}

\setbox0\hbox{\Huge\arab{AlkitAbu AlkabYru}}

\usepackage{fontspec}
\newfontfamily\arabicfont[Script=Arabic,Scale=1.2]{Scheherazade}
\newcommand{\textarabic}[1]{\bgroup\luatextextdir TRT\arabicfont #1\egroup}




\begin{document}

\Huge\arab{AlkitAbu AlkabYru}

\Huge\arab{الكتابُ الكبيرُ}

\Huge\textarabic{الكتابُ الكبيرُ}

\end{document}
5
  • dear David, great to hear from you and thanks for your tip! It works indeed, but I would really be in favor of a solution that does not require a specific loading order. Is there really no way to load an OFM-PFB font after luaotfload has been read by LuaTeX?
    – yannis
    Jun 9, 2015 at 20:44
  • Hi @yannis yes, been a long time! I was just looking... texdoc luaotfload implies ofm fonts should be loaded so my theory is that changing dad in the fd file to [dad] or [file:dad.ofm] or "file:/usr/local/texlive/2015/texmf-dist/fonts/ofm/public/dad/dad" ought to work, but none of them do.... might be worth raising with the luaotfload maintainers Jun 9, 2015 at 20:46
  • this sounds more like what I need! But who are the luaotfload maintainers?
    – yannis
    Jun 9, 2015 at 20:49
  • @yannis they are listed here or (more usefully) a link to github where you could leave an issue I guess ctan.org/pkg/luaotfload?lang=en Jun 9, 2015 at 20:51
  • @yannis moved this to github github.com/lualatex/luaotfload/issues/273 Jun 10, 2015 at 8:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .