0

After translating in pdflatex

\documentclass[12pt]{article}

\pagestyle{empty}   %  no page number

\begin{document}

\title{Article name}
\author{Author}

\maketitle

\end{document}

the first page is numbered.

How do I remove the numbering? Or is there another tool for having no page numbers?

3
  • 2
    \thispagestyle{empty} just after \maketitle.
    – Bernard
    Commented Jun 11, 2015 at 9:17
  • Bernard Thank you - it works. Do you know why it is not ok otherwise?
    – vmk
    Commented Jun 11, 2015 at 9:30
  • Thre way LaTeX builds the page, I guess. But I don't know enough internal details to explain. Andrew Swann's explanation just below seems to be the right one.
    – Bernard
    Commented Jun 11, 2015 at 10:24

1 Answer 1

2

In artcile.cls without the titlepage option, the definition of \maketitle contains

\thispagestyle{plain}

You can discover this by issuing \show\maketitle and looking the .log file, but the output is quite long.

This means that either you need to change the plain layout, or much simpler, you need to issue \thispagestyle{empty} after \maketitle has had effect, but before the page ends. In your example, the latter is sufficient.

Sample output

\documentclass[12pt]{article}

\pagestyle{empty}   %  no page number

\begin{document}

\title{Article name}
\author{Author}

\maketitle
\thispagestyle{empty}

\end{document}

If you had used the titlepage option then there would have been no page number.

Note that other places where \thispagestyle{plain} in article.cls is issued is on the first page of an index if you have one.

See Page number on Index page for defining the plain page style.

Not the answer you're looking for? Browse other questions tagged .