1

I use longtable for building tables in my text works & caption in the bottom. I like this multipage table environnement. But sometime, I see a problem : awful ! My caption is mixed with footnotes… 

An exemple in my context, you can see the 7th footnote & the caption mixed :

Here, a minimal exemple code :

% !TEX encoding = UTF-8 Unicode 
% !TEX TS-program = arara
\documentclass{scrbook}
\usepackage{lipsum}
\usepackage{longtable}
\usepackage{caption}\captionsetup[table]{name=\scshape Tableau, position=bottom}
\usepackage{tabularx}
\usepackage{multicol}
\usepackage{footnote}

\begin{document}
\lipsum[1]\footnote{\lipsum[2]}
\begin{longtable}{|c|c|c|c|}
\hline W&X&Y&Z\\\hline\endfirsthead
\hline W&X&Y&Z\\\hline\multicolumn{4}{|l|}{\emph{suite}}\\\hline\endhead
\hline\multicolumn{4}{|r|}{\emph{suite}}\\\hline\caption[]{Test}\\\endfoot
\caption{Test}\label{tab:test}\\\endlastfoot
A\footnote{ABCD}&B&C&D\\\hline
A\footnote{\lipsum[4]}&B&C&D\\\hline
A&B&C&D\\\hline
A&B&C&D\\\hline
A&B&C&D\\\hline
A&B&C&D\\\hline
A&B&C&D\\\hline
A&B&C&D\\\hline
A&B&C&D\\\hline
A&B&C&D\\\hline
A&B&C&D\\\hline
A&B&C&D\\\hline
A&B&C&D\\\hline
A&B&C&D\\\hline
A&B&C&D\\\hline
A&B&C&D\\\hline
A&B&C&D\\\hline
A&B&C&D\\\hline
A&B&C&D\\\hline
A&B&C&D\\\hline
A&B&C&D\\\hline
\end{longtable}
\end{document}
% arara: xelatex
% arara: xelatex

Some solution ? Thanks for your help.

  • 1
    Table captions belong at the top of tables, not at the bottom. Beside this the problem disappears if you remove the caption package, so its redefinitions are probably the source of the problem. You should notify the author of caption. – Ulrike Fischer Jun 11 '15 at 9:22
  • Thanks, so I have to find another way to rename Table to the french Tableau… This way : tex.stackexchange.com/questions/214874/… using babel & \addto\captionsfrench{\def\tablename{\textsc{Tableau}}} – Zouib Jun 11 '15 at 9:40
  • @UlrikeFischer your answer satisfies my soul ;-) – Zouib Jun 11 '15 at 9:49
  • So, what's the method to cite author in caption ? Exists a fonction to place that, because insert a footnote in the caption don't work… ? – Zouib Jun 11 '15 at 11:52
  • You shouldn't ask new questions in a comment. – Ulrike Fischer Jun 11 '15 at 11:55
0

This response was possible with the help of @UlrikeFischer comments.

Remove caption package is the solution. To conserve the caption's option, use the babel option like captionsfrench.

% !TEX encoding = UTF-8 Unicode 
% !TEX TS-program = arara
\documentclass{scrbook}
%\usepackage{caption}\captionsetup[table]{name=\scshape Tableau, position=bottom}
\usepackage[frenchb]{babel} %
  \addto\captionsfrench{\def\tablename{\textsc{Tableau}}}% to conserve my caption style
\usepackage{lipsum}
\usepackage{longtable}
\usepackage{tabularx}
\usepackage{multicol}
\usepackage{footnote}

\begin{document}
\lipsum[1]\footnote{\lipsum[2]}
\begin{longtable}{|c|c|c|c|}
\hline W&X&Y&Z\\\hline\endfirsthead
\hline W&X&Y&Z\\\hline\multicolumn{4}{|l|}{\emph{suite}}\\\hline\endhead
\hline\multicolumn{4}{|r|}{\emph{suite}}\\\hline\caption[]{Test}\\\endfoot
\caption{Test}\label{tab:test}\\\endlastfoot
A\footnote{ABCD}&B&C&D\\\hline
A\footnote{\lipsum[4]}&B&C&D\\\hline
A&B&C&D\\\hline
A&B&C&D\\\hline
A&B&C&D\\\hline
A&B&C&D\\\hline
A&B&C&D\\\hline
A&B&C&D\\\hline
A&B&C&D\\\hline
A&B&C&D\\\hline
A&B&C&D\\\hline
A&B&C&D\\\hline
A&B&C&D\\\hline
A&B&C&D\\\hline
A&B&C&D\\\hline
A&B&C&D\\\hline
A&B&C&D\\\hline
A&B&C&D\\\hline
A&B&C&D\\\hline
A&B&C&D\\\hline
A&B&C&D\\\hline
\end{longtable}
\end{document}
% arara: xelatex
% arara: xelatex

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.