8

OS: Mac OS X 10.10.3

I had Basic Mac Tex Live 2014 before. I upgraded to Mac Tex Live 2015 and then uninstall Tex Live 2014 by removing the folder /usr/local/texlive/2014basic.

After the upgrade, I found the installed packages missing when compiling the tex file. I checked in the Tex Live Utility and found some additional packages are Not Installed (i.e. the packages that are not distributed with basicTex).

When I tried to install the packages, an error popped out:

The repository at http://mirror.ox.ac.uk/sites/ctan.org/systems/texlive/tlnet
has TeX Live 2015, but you have TeX Live 18446744073709551615 installed.
You need to switch repositories in order to continue.

I wonder where the version 18446744073709551615 come from. In the configuration of distribution, it is shown that TeXLive-2015-Basic is installed.


EDIT

Sorry about not searching carefully. I found the cause and a workaround at the GitHub of Tex Live Utility: Issue 17.

The issue seems to be due to the distribution of Mac TeX Live.

4

I found other people come across the same problem and find the workaround via my question. So I undelete the question.

Please refer to Issues page of TeX Live Utility: here for the cause and workaround.

It seems that a new release of MacTeX Live 2015 has fixed the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.