3

I have emacs 25.0.50 and auctex 11.88.

The auctex command C-c C-v opens a window with the pdf file (compiled with pdflatex). If that command is executed a second time, it does nothing. But in a previous version of auctex, in the second time the command puts the window with the pdf in front. I would like to restore that behaviour. Is it possible?

Thank you!

4
  • What PDF viewer are you using?
    – egreg
    Jun 13, 2015 at 22:51
  • i'm using evince 3.4.0 Jun 13, 2015 at 23:33
  • I don't think something has changed on the AUCTeX side, maybe this has something to do with Evince instead. For what is worth, Okular still works as you describe
    – giordano
    Jun 14, 2015 at 10:01
  • Leo, where is emacs25.. I must be in another internet, and was C-c C-v with sync-view? because with (setq TeX-view-program-list '(("Evince" "evince %o"))) in the init file, C-c C-v does what you want. and speaking of which, I never liked the idea of sync-view
    – doed
    Aug 28, 2015 at 13:47

1 Answer 1

1

... Leo, unless I'm missing something, and under the assumption that TeX-PDF-mode is enabled (default now I think), two consecutive C-c C-v will call the viewer, as long as evince, is specified in TeX-view-program-list in the initialization file with a (setq TeX-view-program-list '(("Evince" "evince %o"))).

As @giordano pointed out, Okular works as expected, at least in my end, without further modification in the initialization file. Of course, this is after customizing TeX-View-program-selection variable, and selecting okular as default viewer for pdf files.

and by the way:

to have that functionality you wanted, without a (setq TeX-view-program-list '(("Evince" "evince %o"))) in .emacs file, TeX-evince-dbus-P :forward must be removed in the tex.el file.

      ("Evince" ,(if (TeX-evince-dbus-p :forward)
         'TeX-evince-sync-view

make and compile auctex.

I'm aware that giordano might not agree with it.

And now that I think about it, wasn't there an issue with it before?

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .