64

How to configure TeXnicCenter to work with Adobe Reader DC? When I building and view current file .tex the following error "Can not execute the command" shows up and the PDF is not generated.

error TeXnicCenter

If there are any related post, could help. Thanks a lot!

5

6 Answers 6

87

The newest trailing number for 2024 update is either acroviewA24 or acroviewR24.

The screenshots below still uses the old trailing number and it no longer works.


This can be solved by using proper settings in TeXnicCenter:

  1. Go to menu: "Build"-> "Define Output Profiles."
  2. Choose profile "LateX to PDF".
  3. Switch to "Viewer" tab
  4. Set-up parameters:

"Executable path" should be something like (check, where have you installed Adobe Reader):

C:\Program Files\Adobe\Acrobat DC\Acrobat\Acrobat.exe

or if you have the 32-bit version:

C:\Program Files (x86)\Adobe\Acrobat Reader DC\Reader\AcroRd32.exe

Note: If you install the 32-bit version on Windows 64-bit, the next automatic update of Adobe Acrobat may change it from 32-bit to 64-bit.

Parameters: "Command", "Server" and "Topic" appears three-times on settings page - be sure to change ALL three appearences correctly.

  • "Server" parameter takes the form

     acroview<Letter><YY>
    

    Where <YY> should be the last two digits of the year in the Adobe Acrobat version (which can be found under Help -> About Adobe Arobat Reader in Adobe Reader), for version 2023.x.x this is 23, and <Letter> is a single letter which is R for the 32-bit version and A for the 64-bit version.

    So for the 64-bit version 2022.001.20085 it would be:

     acroviewA22
    

    For the 32-bit version 2021.007.20099 it would be:

     acroviewR21
    
  • "Topic" parameter should be always:

     control
    
  • "Command" parameter should be twice:

     [DocOpen("%bm.pdf")][FileOpen("%bm.pdf")]
    

    Last instance of "Command" parameter (in "close document..." section) should be:

     [DocClose("%bm.pdf")]
    

After setting everything, confirm "Profiles" dialog and it is done.

Or you can just check following examples

  • Adobe Acrobat Reader DC 64-bit version 2022.001.20085:

enter image description here

  • Adobe Acrobat Reader DC 32-bit version 2022.001.20085:

enter image description here

16
  • 6
    That little acroviewR15 did the trick for me. Great answer!
    – Drarp
    Commented Nov 11, 2015 at 17:52
  • 10
    With the April 2017 update to Acrobat Reader DC, the server parameter has to be acroviewR17.
    – u17
    Commented Apr 13, 2017 at 18:58
  • 5
    With the newest update 2018.009.20044 and beyond, please change all "Server" parameter from acroviewR17 to acroviewR18. Check your Adobe version using Help > About Adobe Acrobat Reader DC.
    – Frenzy Li
    Commented Nov 16, 2017 at 23:29
  • 5
    With the newest update 2019 and beyond, if your using Reader please change all "Server" parameter from acroviewR18 to acroviewR19. Check your Adobe version using Help > About Adobe Acrobat Reader DC. For those with Editor versions (3D standard Pro DC etc.) its now AcroviewA19
    – user170109
    Commented Oct 4, 2018 at 22:57
  • 5
    The "acroviewR18" needs updating to "acroviewR19". I had this error until I tried the latter as above.
    – Shaun
    Commented Oct 22, 2018 at 18:27
28

With the (silent) April 2017 update to Acrobat Reader DC to version 2017.009.20044, the parameters in Jiří's answer don't work anymore. TeXnicCenter just stops responding when trying to view the output with F5.

To solve the problem, simply replace the server parameter from acroviewR15 to acroviewR17 like below.

The dialog can be accessed with Alt + F7. Read more about the new Acrobat Reader version number here.

enter image description here

1
  • I've edited his answer, I think that's more useful for other people than another answer with less votes.
    – domotorp
    Commented Apr 25, 2017 at 8:59
7

To complement the answers by Jiří Chmelík and Frank Seifert.


Update: In October 2018, Adobe Acrobat Reader DC has been updated to 2019.008.20071. acroviewR19 should be used instead, if you have this or a newer version.


In November 2017, Adobe Acrobat Reader DC has been updated to 2018.009.20044. If you have this reader version (or any version starting with 2018), replace the server parameter from acroviewR15 or acroviewR17 to acroviewR18 as shown below. To access this dialogue box, press Alt+F7 in TeXnicCenter, select the "Latex => PDF" profile, then switch to the "Viewer" tab.

enter image description here

To check your reader version, open Adobe Acrobat Reader DC, under "Help" menu, click "About Adobe Acrobat Reader DC". If the version number begins with

  • 2018, set all your Server parameters to acroviewR18,
  • 2017, set all your Server parameters to acroviewR17,
  • 2015, set all your Server parameters to acroviewR15.

Reference for all future versions of Adobe Acrobat Reader DC.

enter image description here

6
  • 1
    Yes, I am already affected by this.
    – Matsmath
    Commented Nov 19, 2017 at 6:46
  • I did all of the above (my version is 2018) nothing works yet. Same error :( Commented Feb 22, 2018 at 22:30
  • @HermanJaramillo Do you have Adobe Acrobat Reader DC? Or one without Acrobat
    – Frenzy Li
    Commented Feb 22, 2018 at 22:32
  • @FrenzyLi Yes I do. Commented Feb 23, 2018 at 12:56
  • I ended up giving up on TexNicCenter in favor of TexWorks which actually works quite well. Commented Feb 24, 2018 at 0:31
5

We're now in 2020, so the version is 20!

enter image description here

1
  • I edited the most-upvoted post with this new information. Commented Feb 17, 2020 at 5:16
2

I had the same problem after Adobe Reader update, solved with:

Executable path = C:\Program Files (x86)\Adobe\Acrobat Reader DC\Reader\AcroRd32.exe
Server = acroviewR15
Topic = control

defined in Build -> Define Output Profiles... -> choose "LateX to PDF" -> Viewer tab (for TeXnicCenter).

2
  • 2
    Welcome to TeX.SX! Can you supplement your answer with some information about where to type that code?
    – egreg
    Commented Jul 1, 2015 at 7:30
  • @egreg: How to open output as pdf directly? Should I need to make some changes in settings of my pdf reader? Right now, only the reader opens, not the document as pdf (which would be more convenient) Commented Mar 6, 2016 at 15:18
0

Reader Config If you use Adobe Reader XI version 11.0.23 (updated June 23, 2018), this trick will work: https://nw360.blogspot.com/2017/03/set-up-pdf-viewer-in-texniccenter.html

View project's output and Forward search: Choose Command line argument and type in "%bm.pdf"

Close document before running (La)TeX: Select DDE command and the command is [AppExit]

Server: arcroviewR11
Topic: Control

The server above is for Adobe Reader. For Adobe Acrobat Pro, use arcroviewA11.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .