2

I'm using multicols package to write a document in two columns, with the article class. It's a known issue though that the package can create big blank spaces between paragraphs to keep some structure of the document, like the case in the image

enter image description here

In the multicols documentation, it says to play with the \tolerance parameter in order to change it. In my case that space only disapears if I set \tolerance = 0. This, though, also messes with the lines width, like in the image below:

enter image description here

Observe that the space between pargraphs is gone, but the lines from the first column now invade the second column.

How could I achieve what's seen in the second image, but keeping the text justified and adjusted to the column?

2
  • Can't you control it \setlength{\parskip}{0.2\baselineskip}, for example. It's in a group and won't affect outside settings
    – user31729
    Jun 16, 2015 at 20:03
  • Please note, that \tolerance is responsible for the breaking into paragraphs, but not for the spacing between the paragraphs, as far as I understood it
    – user31729
    Jun 16, 2015 at 20:52

1 Answer 1

4

This shows the effect of \parskip in a loop, starting from very small values to larger ones. (I won't show 99 pages of output here ;-))

Since \parskip is set in the environment multicols, there is no leaking outside of multicols.

\documentclass{article}

\usepackage{blindtext}
\usepackage{multicol}


\newcommand{\shortchunk}{%
Lorem ipsum dolor sit amet, consectetuer adipiscing elit. Etiam
lobortis facilisis sem. Nullam nec mi et neque pharetra
sollicitudin. Praesent imperdiet mi nec ante. Donec ullamcorper,
felis non sodales commodo, lectus velit ultrices augue, a
dignissim nibh lectus placerat pede.
}

\usepackage{pgffor}
\usepackage{calc}

\begin{document}

\newlength{\foo}
\setlength{\foo}{0.002\baselineskip}%

\begin{multicols}{2}
\foreach \x in {1,...,1000} {%
  \setlength{\parskip}{\x\foo}%
  \shortchunk

}
\end{multicols}

\end{document}
1
  • Thanks! So it was \parskip the parameter I had to change. Jun 17, 2015 at 0:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .