1

I am trying to add a new button to the WinEdt 9.1 toolbar menu. I have already put in place the command in the MainMenu.ini file:

ITEM="Matlab"
CAPTION="Matlab"
IMAGE="Matlab"
MACRO="Run('"C:\Program Files\MATLAB\R2014b\bin\matlab.exe" "%N%T""','%P','',100,0,'','','',111);"`

and also updated the Toolbar.ini file. However, in the the toolbar, the place where the icon should show up, shows up blank. The new icon is a 16x16 .png file in the "...\WinEdt Team\WinEdt9\Bitmaps\Images" folder. If I hover my mouse around the place where the icon should show up on the toolbar, I do see the caption ("Matlab") and a raised blank box. I know in the past WinEdt version (version 5) that you had to modify a WinEdt.btn file and add a line with your new icon, but I do not see that file anymore. Is there somewhere else you have to specify your newly added icon?

  • Read the comments in images.ini. – Ulrike Fischer Jun 17 '15 at 21:31
  • Did you install the bitmaps in your private settings directory (%b)? – Bernard Jun 17 '15 at 21:55
  • @Bernard, I put the bitmap into the C:\Program Files\WinEdt Team\WinEdt 9\Bitmaps\Images folder. I also went into the Images.ini file and modifed "USE_LOCAL_FOLDER=1" in the IMAGE_WIDTH=16 and IMAGE_HEIGHT=16 section but I still cannot see the icon. – Joe Jun 17 '15 at 21:57
  • From my experience with WinEdt 8, it should be in C:\Users\YourName\AppData\Roaming\WinEdt Team\WinEdt 9\Bitmaps, and modifications to MainManu.ini should be in C:\Users\Bernard\AppData\Roaming\WinEdt Team\WinEdt 9\ConfigEx. – Bernard Jun 17 '15 at 22:01
  • @Bernard, I do not see the Bitmaps folder in the path that you suggested. There are only the folders: Config, ConfigEx, Dict and Exex and then some other files. – Joe Jun 17 '15 at 22:07
3

The advice Read the comments in images.ini. – Ulrike Fischer Jun 17 '15 at 21:31 given by Fischer is perfectly correct, but perhaps too brief for anyone searching for a solution to winedt icon problems.

In WinEdt 9 and 10 (10.1 is the Sept 2016 official version) there is a file called Images.ini in the program folder. I found it in subdirectory ConfigEx.

Read the text therein (as Fischer suggested).

It says to use local images, you must edit Images.ini and change the settings. The simplest edit is to change the digit (either 0 or 1) after USE_RESOURCE_DLL and USE_SOURCE_FOLDER.

A simple example is to replace the 16x16 AcroRead and AcroFind images with similar 16x16 images for Sumatra PDF. The AcroRead.png image was found in subdirectory Bitmaps/Images. A search for this file name will unearth its location in any WinEdt install. A safe experiment is to rename AcroRead.png to AcroRead.png.orig and then copy a new 16x16 image to this directory with file name AcroRead.png.

Please note that installs of winedt 5,6,7,8 did not have a resource DLL for images. The DLL is used by default in winedt 9, 10. The BitMaps/Images directory is still there, but not used unless enabled (see above).

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.