2

I have two issues with my beamer presentation. I am using stockton theme. find it here - Stockton theme

The first issue is about the title slide. The background is such that, I want to move elements of the title to the right of the black portion (including the orange box). How can I do that? other frames

The second issue is that on other slide some of my credentials appear in the background (see font in white over black background). How can I get rid of that? enter image description here

I am attaching the minimal example:

    \documentclass[slidestop,compress,mathserif]{beamer}        

\usetheme{Stockton}
\useoutertheme{miniframes}

\usecolortheme{default}

\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage{tikz}
\usepackage{geometry}
\usepackage{graphicx}
\usepackage{amssymb}
\usepackage{epstopdf}
\usepackage{amsmath}    % this permits text in eqnarray among other benefits
\usepackage{color}              % gives color options
\usepackage{url}        % produces hyperlinks
\usepackage[english]{babel}
\usepackage[latin1]{inputenc}
\usepackage{colortbl}   % allows for color usage in tables
\usepackage{multirow}   % allows for rows that span multiple rows in tables
\usepackage{xcolor}     % this package has a variety of color options
\usepackage{verbatim}

\setbeamercolor{normal text}{fg=black,bg=white}


\usebackgroundtemplate%
{%
    \includegraphics[width=\paperwidth,height=1.4\paperheight]{placeholder.png}%
}

\title[My presentation title]{My presentation title}
\author{My name \vskip0.5cm My title \vskip1cm My team}


\begin{document}        

\begin{frame}[plain]
  \titlepage
\end{frame}

\frame[shrink]{\frametitle{Outline}\tableofcontents[hideallsubsections]}


\end{document}

P.S. output will be slightly different from images, but idea is the same.

5
  • For your second problem, try to remove these \vskips from your authors. Or at least give a short version for the footline with \author[short version without vskip]{My name \vskip0.5cm My title \vskip1cm My team}. [unable to test it, because your vskip gives errors with my latex installation] Jun 19, 2015 at 15:20
  • @samcarter : that worked. thanks a lot. I still need help with the first part.
    – GKS
    Jun 20, 2015 at 0:52
  • Any help on the first part?
    – GKS
    Jul 10, 2015 at 0:44
  • Unfortunately I am missing the Stockton theme and can not compile your example - so it is difficult to help. I think you probably have to define your own title page, for a start maybe look at tex.stackexchange.com/a/25318/36296 Jul 10, 2015 at 8:25
  • @samcarter I have added the theme in the question. Any help will be appreciated. I am still looking for way to solve it.
    – GKS
    Jul 14, 2015 at 2:59

1 Answer 1

3

The theme uses the title page template as defined by the default inner theme, so you can do a redefinition of this template, as the example below shows. A placed the title page elements inside a columns environment; the column to the left is empty and the one to the right contains the information. Change their widths in the lines signales % Here in the example code. I also reduced the width for the boxes containg the information; adjust this width according to your needs as the wd value (also signaled % Here in my example).

enter image description here

\documentclass{beamer}        

\usetheme{Stockton}
\useoutertheme{miniframes}

\usecolortheme{default}

\makeatletter
\defbeamertemplate*{title page}{mydefault}[1][]
{
  \vbox{}
  \vfill
  \begingroup
   \begin{columns}
   \column{0.6\paperwidth}% Here
   \mbox{}
   \column{0.4\paperwidth}% Here
    \begin{beamercolorbox}[sep=8pt,center,#1]{title}
      \usebeamerfont{title}\inserttitle\par%
      \ifx\insertsubtitle\@empty%
      \else%
        \vskip0.25em%
        {\usebeamerfont{subtitle}\usebeamercolor[fg]{subtitle}\insertsubtitle\par}%
      \fi%     
    \end{beamercolorbox}%
    \vskip1em\par
    \begin{beamercolorbox}[sep=8pt,center,#1]{author}
      \usebeamerfont{author}\insertauthor
    \end{beamercolorbox}
    \begin{beamercolorbox}[sep=8pt,center,#1]{institute}
      \usebeamerfont{institute}\insertinstitute
    \end{beamercolorbox}
    \begin{beamercolorbox}[sep=8pt,center,#1]{date}
      \usebeamerfont{date}\insertdate
    \end{beamercolorbox}\vskip0.5em
    {\usebeamercolor[fg]{titlegraphic}\inserttitlegraphic\par}
   \end{columns}
  \endgroup
  \vfill
}
\setbeamertemplate{title page}[mydefault][colsep=-4bp,rounded=true,shadow=\beamer@themerounded@shadow,wd=4cm]% Here
\makeatother

\title[My presentation title]{My presentation title}
\author{My name My title My team}

\begin{document}        

\begin{frame}[plain]
  \titlepage
\end{frame}

\end{document}

As a final remark, you are loading packages in such a way that errors will appear: you load inputenc twice with different encoding options; load it just once with the necessary encoding. Besides, there's no need to explicitly load color and graphicx since beamer already loads them

2
  • This appears to do the trick. Wish I had enough reputation to upvote this!!
    – GKS
    Jul 14, 2015 at 15:58
  • @GKS While you gain enough reputation to up-vote the answer, you can still accept it :) See How do you accept an answer?. Jul 14, 2015 at 16:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .