1

I'm using BibTex to make my bibliography. However, I did not use in-text citations, so am manually inputting all of my entries in Latex using \nocite{Reference} in the order I specifically want them in. I have lots of different reference types, including misc for citing webistes. When I generate my bibliography using LaTex, all of the misc references are bumped to the top of the bibliography, although the order of the rest are preserved. Any way to address this?

Reference example:

@misc{file2}, 
title     = "XXXX (2013). XXX.",
}

Latex code (I'm using a non-numbered reference list):

\bibliographystyle{plain}
    \renewcommand\@biblabel[1]{}
    \makeatother

\nocite{file1}
\nocite{file2}
\nocite{file3}
\bibliography{Bibliography}

If file1 and file3 are @book references or whatever, the output is

file2

file1

file3

  • 1
    Welcome. Isn't the default sort order alphabetical by author? There is no author so it will come first in the ordering. – cfr Jun 20 '15 at 16:51
  • Hm. I suppose I could just use author to fill in my citation as opposed to title. Thanks! – TexNoob Jun 20 '15 at 16:56
  • 1
    Well, you should really put the author in the author field, the year in the year field and so on. You can use, I think, key to give BibTeX some help sorting non-standard entries. – cfr Jun 20 '15 at 18:09
  • Using biblatex with the option sorting=none would probably make things easier. – Bernard Jun 20 '15 at 18:26
1

plain-style sort your entries alphabetically after the name of the first author.

In your case, it will be sorted by title.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.