0

Yesterday, I was happily compiling with pdfLaTeX in kile on my kubuntu 14.4, but today, pdfLaTeX is gone from kile. What happened, how do I get it back?

pdflatex still seems to be installed:

$ pdflatex --version
pdfTeX 3.1415926-2.5-1.40.14 (TeX Live 2013/Debian)
kpathsea version 6.1.1
Copyright 2013 Peter Breitenlohner (eTeX)/Han The Thanh (pdfTeX).
There is NO warranty.  Redistribution of this software is
covered by the terms of both the pdfTeX copyright and
the Lesser GNU General Public License.
For more information about these matters, see the file
named COPYING and the pdfTeX source.
Primary author of pdfTeX: Peter Breitenlohner (eTeX)/Han The Thanh (pdfTeX).
Compiled with libpng 1.2.49; using libpng 1.2.50
Compiled with zlib 1.2.8; using zlib 1.2.8
Compiled with poppler version 0.24.5

Also compiling with

$ pdflatex mydocument.tex

worked fine.

Can I reset kile to "factory settings" somehow?

  • Is it gone from the Build | Compile Menu as well? If it is still there, you may have accidentally altered your toolbar (has happened to me before...). – vaettchen Jun 20 '15 at 21:03
  • What do you mean by 'gone'? Where was it before that it now isn't? – cfr Jun 20 '15 at 21:23
  • No, it is not in the Build | Compile Menu. Yes, it was there before and now it's gone. – Make42 Jun 21 '15 at 9:15
  • What is in that menu? Is it empty? Is everything else still there? Settings > Configure Kile > Tools > Build. Is there an entry for it still in the list? On the right, there is a tab 'Menu' which lets you add entries to the menus. It should say 'Compile'. If not, can you set it there? If you haven't customised your tools, you could also try 'Restore Default Tools'. – cfr Jun 21 '15 at 16:25
1

Close Kile, then go to folder /home/{USER_NAME}/.kde/share/apps/kile/ and remove or rename the file kileui.rc. Reopen Kile and check if it solves your problem.

Another option is to go to Settings > Configure Kile > Tools > Build and click on Restore Default Tools... on the right.

  • The second option is what worked for me, by the way. – Make42 Jul 4 '15 at 14:28
  • @user49283 The first one is for the missing Settings option in the Kile's menu. Sometimes it gets hidden with no reason, especially when you customized it. – Carlos Viegas Jul 5 '15 at 20:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.