Update: on February 10th, 2017, the TeX processing system of arXiv has been updated to TeX Live 2016, so this should be no more an issue.

I'm trying to submit a paper to the arXiv using the newest MNRAS style files. The packages that creates a problem for me is:


The first error I got is ! LaTeX Error: File `newtxtext.sty' not found and the same for newtxmath.sty so it seems arXiv do do have these packages(?). I tried to add the two style files together with the submission (Do I need to add other files to make this package work?) and this time it failed with error:

.! LaTeX Error: This NFSS system isn't set up properly.

If I comment out \usepackage{newtxtext,newtxmath} everything works perfectly, but the style will not be the same as it is with this package.

Have anybody else experienced this and know why this happens? Is there a simple fix for this?

Please let me know if I need to add more details.

Added: The other packages I use are:

  • 1
    Try the "old" packages \usepackage{times,txfonts}. It's not the same you want, but at least should work with the old TeX distribution arXiv uses. – giordano Jun 21 '15 at 18:17
  • Thanks for the suggestion. I tried it and adding txfonts fails with ! LaTeX Error: Too many math alphabets used in version normal.. – Winther Jun 21 '15 at 18:21
  • Ok, then you should add more information about your preamble. – giordano Jun 21 '15 at 18:23
  • @giordano I have done this now. Anyway, your suggestion fixed the important problem I had that my tables became larger than the pagesize. This was fixed by adding the times package it seems so thanks for that. – Winther Jun 21 '15 at 18:26
  • First of all, make sure you are loading only packages you actually use (e.g., latexsym is useless if you load amssymb, as in your case; are you really using symbols from wasysym package?), then take look at this question since you load bm (are you really using it?) – giordano Jun 21 '15 at 18:58

The packages newtxtext and newtxmath are a replacement for the old package txfonts (and times). As of June 2015, arXiv is running TeX Live 2011, and the packages newtxtext and newtxmath weren't included in it.

If you still want to use Times-like fonts, the simplest solution is to replace those packages with the package they superseded, i.e. use


in place of


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.