I'm trying compiling this latex template example (CHI Extended Abstracts template) under linux (XeTeX, Version 3.1415926-2.2-0.9997.4 (TeX Live 2010/Arch Linux) using xelatex.

This is the output I'm getting: http://sprunge.us/YaXi

It seems that it's having troubles finding Helvetica, but helvetica is installed: fc-list http://sprunge.us/GChE

Can you guys help?

UPDATE: Trying to simplify the issue, I've been suggested on #latex to try with a simpler example:





Which fails just as the template above. See http://sprunge.us/GJdG

  • 5
    You also have Nimbus Sans L installed, which is nearly identical to Helvetica. You could try that. Also, you shouldn't use babel with xelatex, but Polyglossia instead. (Though I've noticed that causes problems for blindtext.) But I don't think that's your problem.
    – frabjous
    Aug 8, 2011 at 13:30
  • Try this: \setmainfont{Helvetica Regular} Let me know the result.
    – Sam Qasbah
    Aug 8, 2011 at 15:56
  • Yeah, using Nimbus Sans L worked just fine. Aug 10, 2011 at 7:13
  • 2
    @frabjous: We have TeX Gyre Heros now, please don't use the inferior GhostScript fonts anymore. Jun 17, 2012 at 21:30
  • 1
    Check the type of the Helvetica fonts you have (fc-list -v Helvetica | grep fontformat). At least here, Helvetica is in PCF, a bitmap font format, which can't be used with Xe(La)TeX, even if listed by fc-list. On how to filter fc-list, and on what may be the same issue, see tex.stackexchange.com/questions/25786/…
    – njsg
    Jun 17, 2012 at 21:52

2 Answers 2


I suspect your Helvetica font is not properly installed. fontspec easily chokes on fonts that are duplicated for example (two different files providing the same font).

Check your installation.

Also, if you're not picky on the exact font to use, @frabjous' suggestion to use Nimbus Sans L (a free Helvetica clone) is a good idea.

  • Yes, this is probably the case.. don't know how can I fix this though. Aug 10, 2011 at 7:12

I think that


should work. It's worked for me

  • 5
    \usepackage{tgheros} please. Jun 17, 2012 at 21:32
  • 3
    @MartinSchröder: Why?
    – doncherry
    Jun 18, 2012 at 13:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .