8

Since yesterday's (22.6.2015) update my MiKTeX 2.9 on a USB stick no longer works. Trying to start it on a Windows 7 desktop returns the error

Windows API error 2: could not find file

The only thing I can think of is a clean install, which I would rather not do.

  • I can confirm this error. It happened to me to. It seems that mixtex delete some important files, and does not copy in new one. When I run the update, I fist got the error that mixtex could not find the package manager due to missing msvcp120.dll-file. When I closed the icontray-app and restart, the cmd-file did not find the icon-tray.exe. I checked, and the files did not exist on my system. – Sveinung Jun 23 '15 at 18:15
  • I can confirm this error also on Win8.1 – Dzaic Jun 24 '15 at 6:51
  • @Sveinung: I had (in a normal, single-user, non-portable miktex) also an error regarding a missing dll and couldn't start the package manager. But the command line version worked fine and after mpm --install=miktex-vc120-bin everything was ok (perhaps you need a mpm --update-db first). – Ulrike Fischer Jun 24 '15 at 13:36
  • So, is there any chance, that this issue gets resolved in one of the next update cycles? – user80632 Jun 24 '15 at 14:25
  • @UlrikeFischer I just get an error mpm.exe is not recognised as a command. In the portable version, lot of .exe-files were removed during the update (also the icon-tray program). – Sveinung Jun 24 '15 at 21:13
7

It helped me:

  1. Run mo.exe

  2. From "packages" tab select miktex 2.9 executables -> mpm cli, miktex-vc120-bin, miktex-internal-bin

  3. Update again.

(miktex portable with /bin added to path)

  • Well, I got the error that the program could not be run because mvscp120.dll was missing. The problem seems to be that I run the update from the GUI. I will try to reinstall the portable version and update the .dll from the command line. – Sveinung Jun 25 '15 at 8:42
  • 1
    @Sveinung: Get msvcp120.dll free from Microsoft. It is part of Visual C++ 2013 redistributable. Install it, then do what Stefan Kottwitz wrote above. Worked for me. If it works for you too, then be sure to mark SK's post as the solution. – RobtA Jun 25 '15 at 23:47
  • @RobtA It is much better to use Ulrike Fischer's receipt: mpm --install=miktex-vc120-bin. – Sveinung Jun 26 '15 at 9:51
  • @Sveinung: Ah, yes. I forgot that Miktex will automatically make other changes, as needed. It will even do this midway through processing a document! I use TeX on both Linux as Texlive, and Windows as Miktex. – RobtA Jun 26 '15 at 13:03
  • Different ones were missing for me, but this worked. – Steven Jeuris Apr 29 '16 at 14:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.