4

I wanted to install the MinionPro font for Latex (I obtained them via the free Adobe Reader). I found a description here which seemed reasonably easy (for a noob like me):

http://www.clarkdonley.com/blog/2015-03-07-installing-minionpro-for-latex-on-mac-os-x-yosemite.html

In order to use the FontPro I need the so-called LCDF Typetools, so I downloaded this:

http://www.lcdf.org/type/

Here already I have a problem since I get the following error when I try to configure these lcdf typetools:

==============

I can't find the kpathsea library and/or header files. Tell me where to look using the --with-kpathsea=PREFIX option (header files should be under PREFIX/include/kpathsea, and library under PREFIX/lib), or disable support using --without-kpathsea.

==============

So where to find this kpathsea library? I also tried to just forget about this and follow the steps of FontPro, but then I get stuck at step 4 when I run the makeall MinionPro script.

Eventually I just want to be able to include \usepackage{MinionPro} in my Latex files and use the MinionPro font.

Any help is welcome (keep it understandable for me though, probably you have noticed that I don't understand much of this stuff)! Thanks in advance.


The error I get (using FontPro):

AYK-3:scripts ayasirkilic$ ./makeall MinionPro
Chosen font family is MinionPro
otfinfo: otf/MinionPro-Regular.otf: No such file or directory
otfinfo: otf/*otf: No such file or directory
Found font version
No matching glyph list found
Please run "scripts/generate-glyph-list.sh > scripts/MinionPro-glyph-list-" after this script and use the resulting file with a clean script folder
cp: directory enc does not exist
cp: directory fontinst does not exist
cp: directory kerning does not exist
Creating PostScript fonts ...
cfftot1: otf/MinionPro*.otf: No such file or directory
./makeall: line 69: 10306 Segmentation fault: 11  t1dotlessj --quiet "$base.pfb" "${base}LCDFJ.pfb"
Creating TeX metrics ...
Can't open perl script "scripts/filtererr": No such file or directory
./makeall: line 92: scripts/maketfm: No such file or directory
mv: rename *.pfb to pfb/*.pfb: No such file or directory
maketfm failed, exiting ...

AYK

7
  • You probably already have the tools installed. What distribution of TeX are you using on which platform?
    – cfr
    Jun 23, 2015 at 13:59
  • I think MacTex (I hope this makes sense?) and I use TeXstudio as an editor. If there is a way to find this out easily tell me.
    – AYK
    Jun 23, 2015 at 14:07
  • Yes. Then you should have the lcdf tools installed already. So you don't need to worry about installing those, I don't think. What error do you get when you run make?
    – cfr
    Jun 23, 2015 at 14:11
  • 1
    I edited my question above so that you can read it there.
    – AYK
    Jun 23, 2015 at 14:14
  • 1
    @AYK - You have to run ./scripts/makeall MinionPro; don't cd into scripts/ directory. Jun 23, 2015 at 18:20

4 Answers 4

7

Follow ONLY steps 1-4 from the linked instructions. Steps 5-6 and 8 are simply wrong. Step 9 is pointless and step 7 is inefficient.

Instead, after completing step 4, do this:

./scripts/install $(kpsewhich -var TEXMFLOCAL)  
mkdir -p --parents $(kpsewhich -var TEXMFLOCAL)/web2c
echo Map MinionPro.map >> $(kpsewhich -var TEXMFLOCAL)/web2c/updmap.cfg
mktexlsr $(kpsewhich -var TEXMFLOCAL)
updmap-sys

If you are on Mac OS X and have not enabled root and are using a default MacTeX installation, you'll have to prefix every step with sudo or run sudo sh to get a privileged shell before you start.

Note that this is not tested as I do not use FontPro and am not using a Mac. I'm assuming that the instructions are basically right about how FontPro works. Given they are not reliable on how TeX Live works, this may not be a safe assumption.

Caveat emptor...

9
  • First of all thanks, with the comment of Arash Esbati I was able to complete step 4. Then I used the first line of you, everything worked fine. But at the second step I get to see: mkdir: illegal option -- -. I just copied exactly what you wrote.
    – AYK
    Jun 23, 2015 at 21:31
  • Try just mkdir -p $(kpsewhich -var TEXMFLOCAL)/web2c then.
    – cfr
    Jun 23, 2015 at 22:19
  • Yes I did this and it worked, but then the next commands does not work: sudo: echo Map MinionPro.map >> /usr/local/texlive/2013/../texmf-local/web2c/updmap.cfg: command not found
    – AYK
    Jun 23, 2015 at 22:50
  • 1
    Oh, I see. Use the sudo sh method to get a shell and type exit when you are done. It is because of the redirection. Or you can just open /usr/local.../updmap.cfg in an editor, with sudo, and then add the line Map MinionPro.map to it. (The file probably doesn't exist and will be created. But just in case it does exist, add the line to whatever is there already.) This is one reason I dislike Apple's anti-root policy. (And I hear it is going to get worse and they are going to make it even more difficult for people to alter their systems.)
    – cfr
    Jun 23, 2015 at 23:09
  • It worked finally, thank you for your patience!
    – AYK
    Jun 24, 2015 at 2:10
1

Here are my instruction that I obtained by testing different tutorials. I do use Mac but once I did the install on Windows.

For Mac:

How to install?

  1. Run kpsexpand '$TEXMFLOCAL' in terminal. That will be the location of the fonts.
  2. Go to minion/ folder (this folder is in the zip with this document) from terminal
  3. Run $ sudo mkdir -p /usr/local/texlive/2016basic/texmf-local/fonts/type1/adobe/MinionPro
  4. Run 
$ sudo cp pfb/*.pfb /usr/local/texlive/2016basic/texmf-local/fonts/type1/adobe/MinionPro
  5. Run 
$ cd /usr/local/texlive/2016basic/texmf-local 
 $ sudo unzip sudo unzip /Users/pacha/Google\ Drive/tipografías/latex/minion/metrics-base.zip 
 $ sudo unzip sudo unzip /Users/pacha/Google\ Drive/tipografías/latex/minion/enc-2.000.zip
  6. Run: $ sudo -H mktexlsr $ sudo updmap-sys --enable Map=MinionPro.map $ sudo -H updmap-sys

Solving issues

\usepackage[openg]{Minion Pro} won’t show the letter “g” and \ell won’t work with this typography. Here is the solution.

Go to /usr/local/texlive/2016basic/texmf-local/enc/dvips/adobe

Run $ sudo nano base-MinionPro-ab.enc

With ctrl+w replace

  • /afii61289 by /uni2113
  • /afii10069.ital by /uni0434.ital

For Windows:

  1. Create the folder C:\texfonts
  2. Unzip lucida-type1.zip and lucimacros.zip in the folder in (1).
  3. Go to Miktex settings (Start > Programs > MiKTeX > Maintenance)
  4. Add the folder in (1) (see image #1)
  5. Update FNDB and formats (see image #2), click “apply” and “accept”

If it doesn't work do these additional steps in old Windows versions: (**) Enabling the Lucida map file under MiKTeX:

  1. Edit the map configuration file updmap.cfg. In a DOS Window/Command Prompt window, run: initexmf --edit-config-file updmap. You'll want to edit this in a text editor such as Notepad. If the file or any of the leading directories do not exist, create them.
  2. Add this one line to updmap.cfg and save it: Map lucida.map
  3. Back at the DOS prompt, run: initexmf --mkmaps (Ignore any error messages.)

Image #1 enter image description here

Image #2 enter image description here

2
  • "Go to minion/ folder (this folder is in the zip with this document) from terminal" What folder? Which ZIP?
    – stx932
    Mar 13, 2018 at 14:02
  • sorry, this was a guide that I wrote for a company where I worked that zip is the zip file that you get when you buy the font Mar 13, 2018 at 16:45
1

The following worked for me with MacTeX 2020.

See https://github.com/sebschub/FontPro for upstream instructions.

  1. Clone sebschub/FontPro
  2. Install lcdf-typetools (brew install lcdf-typetools)
  3. Copy MinionPro fonts into FontsPro/otf
  4. Run sudo scripts/makeall MinionPro
  5. Run sudo ./scripts/install
1

Just a note (I don't have the MinionPro font so can't test), but if you are using LuaLaTeX and the fontspec package, you apparently don't need to convert the fonts, and you can just copy the .otf files in the project folder as reported here Minion Pro in Overleaf , not exactly the same as Adobe's Minion and load it with:

\usepackage{fontspec}
\setmainfont{Minion Pro}

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .