2

I have a .tex file which works fine under Windows/MikTeX, but fails to produce a PDF in Linux Mint 17/TeXLive 2013.

I looked through various similar questions posted on this site, but none seemed to fit to my situation:

I am beginner in Linux, so please forgive me if the answer is trivial. I tried the following suggestions from the above links:

  • Running "udpmap": did not help.
  • Running commands "kpsewhich mathb.tfm", "kpsewhich mathb9.tfm", "kpsewhich mathabx", "kpsewhich mathabx": gave no result.

Minimal example that gives me the problem:

\documentclass[11pt,a4paper]{amsart}
\pagestyle{plain}

\DeclareFontFamily{U}{mathb}{\hyphenchar\font45}
\DeclareFontShape{U}{mathb}{m}{n}{
<-6> mathb5 <6-7> mathb6 <7-8> mathb7
<8-9> mathb8 <9-10> mathb9
<10-12> mathb10 <12-> mathb12
}{}
\DeclareSymbolFont{mathb}{U}{mathb}{m}{n}
\DeclareMathSymbol{\llcurly}{\mathrel}{mathb}{"CE}
\DeclareMathSymbol{\ggcurly}{\mathrel}{mathb}{"CF}

\begin{document}
\[ a \llcurly b \quad a \ggcurly b \]
\end{document}

Error:

$ pdflatex test.tex 
This is pdfTeX, Version 3.1415926-2.5-1.40.14 (TeX Live 2013/Debian)
 restricted \write18 enabled.
entering extended mode
(./test.tex
LaTeX2e <2011/06/27>
Babel <3.9h> and hyphenation patterns for 2 languages loaded.
(/usr/share/texlive/texmf-dist/tex/latex/amscls/amsart.cls
Document Class: amsart 2009/07/02 v2.20.1
(/usr/share/texlive/texmf-dist/tex/latex/amsmath/amsmath.sty
For additional information on amsmath, use the `?' option.
(/usr/share/texlive/texmf-dist/tex/latex/amsmath/amstext.sty
(/usr/share/texlive/texmf-dist/tex/latex/amsmath/amsgen.sty))
(/usr/share/texlive/texmf-dist/tex/latex/amsmath/amsbsy.sty)
(/usr/share/texlive/texmf-dist/tex/latex/amsmath/amsopn.sty))
(/usr/share/texlive/texmf-dist/tex/latex/amsfonts/umsa.fd)
(/usr/share/texlive/texmf-dist/tex/latex/amsfonts/amsfonts.sty)) (./test.aux)
(/usr/share/texlive/texmf-dist/tex/latex/amsfonts/umsa.fd)
(/usr/share/texlive/texmf-dist/tex/latex/amsfonts/umsb.fd)
kpathsea: Running mktextfm mathb9
/usr/share/texlive/texmf-dist/web2c/mktexnam: Could not map source abbreviation  for mathb9.
/usr/share/texlive/texmf-dist/web2c/mktexnam: Need to update ?
mktextfm: Running mf-nowin -progname=mf \mode:=ljfour; mag:=1; nonstopmode; input mathb9
This is METAFONT, Version 2.718281 (TeX Live 2013/Debian)

kpathsea: Running mktexmf mathb9
! I can't find file `mathb9'.
<*> ...:=ljfour; mag:=1; nonstopmode; input mathb9

Please type another input file name
! Emergency stop.
<*> ...:=ljfour; mag:=1; nonstopmode; input mathb9

Transcript written on mfput.log.
grep: mathb9.log: No such file or directory
mktextfm: `mf-nowin -progname=mf \mode:=ljfour; mag:=1; nonstopmode; input mathb9' failed to make mathb9.tfm.
kpathsea: Appending font creation commands to missfont.log.

! Font U/mathb/m/n/9=mathb9 at 9.0pt not loadable: Metric (TFM) file not found.
<to be read again> 
                   relax 
l.16 \begin{document}

System background:

  • Linux Mint 17
  • TeX Live 2013 (fresh install, has never been installed on this system before)

PS. Few years ago I had a similar problem on Windows/MikTex platform: Loading symbol from mathb font does not work when document class is amsart

Then the error was in .tex code; right now the error seems to be in my platform (because the same .tex file works on other platforms and computers).

  • @cfr I will try with to go with the "vanilla" version. You might want to add this suggestion as an answer, so I can accept it if it works out for me. – Rauni Jun 24 '15 at 12:57
  • Done. I've converted my comments to an answer and added a bit more information. – cfr Jun 24 '15 at 13:30
  • Thank You. It might take me a few days before I actually get to installing the vanilla version, so You will have to wait a bit for "accept" :) – Rauni Jun 26 '15 at 6:01
1

Don't run updmap. If you have run updmap, delete the directory named .texliveYYYY (e.g. .texlive2013) from your home directory. Note that the name of the directory begins with a dot. To be safe, rename it rather than deleting it. (Deleting the directory is safe but deleting some other directory which you think it this one may not be at all safe.)

Always use updmap-sys rather than updmap to avoid problems when updating your TeX distribution. Only use updmap if you have no choice (e.g. you don't administer the machine and can only write to your home directory etc.). In that case, you need to rerun updmap every time the administrator updates the installation of TeX Live.

It sounds as if you do not have the relevant package installed. It is part of TeX Live. You will need to figure out where your distro has packaged it if you want to use your distro's TL packages. I would recommend scrapping your distro's TL and installing the vanilla version from upstream. But if you don't want to do that, you have to get to grips with where they've put the packages you want.

For instructions explaining how to install vanilla TeX Live from upstream see How to install "vanilla" TeXLive on Debian or Ubuntu?. Although the instructions there are for Debian or Ubuntu, they can be adapted for other GNU/Linux distributions. Since Mint is apt-based, minimal modifications will be required.

Here's the result of compiling your MWE with a current version of upstream's TeX Live on GNU/Linux:

fonts from TeX Live

  • Worked like a charm! One remark though: updmap put files into directory ~/.texmf-var , not ~/.texlive2015. – Rauni Jun 26 '15 at 22:37
  • @Rauni Oh, OK. I guess that was a Mint decision. Vanilla TeX Live uses ~/.texliveYYYY so if you have multiple years' installed, things don't get mixed up. Glad you got it sorted, though. Sorry - I didn't think of Mint putting those files elsewhere. – cfr Jun 26 '15 at 23:44
  • 1
    No problem, You helped me a lot :) – Rauni Jun 29 '15 at 21:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.