2

My thesis format requires that pages appear before the first chapter to be numbered with Roman numerals and the main content of the thesis to be numbered with Arabic numbers. It seems that the arabic support in babel allows the Table of Contents to switch the page numbering style for the later appear pages to Arabic. My thesis content relies heavily on arabic content so I can not switch the babel support.

This is the shortest example that produces the problem. Notice that the number of the TOC page is "5" instead of "V". If we remove arabic from babel the problem will be fixed.

\documentclass[12pt]{book}
\usepackage[arabic,main=english]{babel}


\begin{document}

\pagenumbering{gobble}
\title{\bf{Title of Dissertation}}

\vspace*{3\baselineskip}
\centerline{\bf{Polyglot: A Massive Multilingual Natural Language Processing Pipeline}}
\vspace*{1\baselineskip}
\centerline{A Dissertation presented}

\newpage

\pagenumbering{roman}
\setcounter{page}{2}

\centerline{\bf{Stony Brook University}}
\vspace*{1\baselineskip}

\newpage

\centerline{Abstract of the Dissertation}
\vspace*{1\baselineskip}
\centerline{\bf{Polyglot: A Massive Multilingual Natural Language Processing Pipeline}}

\newpage
\vspace*{4\baselineskip}
\centerline{\textit{Dedicated to the refugee children across the world.}}


\tableofcontents

\listoffigures


\listoftables




\newpage
\renewcommand{\thepage}{\roman{page}}
\centerline{\bf{List of Abbreviations}}
\vspace*{4\baselineskip}
\begin{tabular}{ll}
NLP & Natural Language Processing \\
NER & Named Entity Recognition\\
POS & Part of Speech\\
OOV & Out of Vocabulary \\
RNN & Recurrent Neural Network\\
LOC & Location \\
ORG & Organization \\
PER & Person
\end{tabular}


\newpage
\centerline{\bf{Acknowledgements}}
\vspace*{4\baselineskip}
I am grateful to have my PhD advisor

\newpage
\centerline{\bf{Publications}}
\vspace*{2\baselineskip}

\mainmatter


\chapter{Introduction}

\end{document}

Here is the wrong output

Wrong output

Here is what it should look like

Right output

  • If you can use XeLaTeX with polyglossia there is no problem. – Henk Metselaar Jun 24 '15 at 7:31
3

Well your example is certainly not the shortest possible example. Actually it is enough to call \tableofcontents.

The problem is that arabic loads the arabicore.sty which redefines all pagestyles (and other things, I don't have the impression that style author really thought about multilanguage documents).

The best would probably to reset the pagestyles e.g. with fancyhdr.

\documentclass[12pt]{book}

\usepackage[arabic,main=english]{babel}

\usepackage{fancyhdr}
 \pagestyle{fancy}
 \fancypagestyle{plain}
  {\fancyhf{}\cfoot{\thepage}}
 %.... more fancyhdr settings

\begin{document}
\pagenumbering{roman}
blblal

\tableofcontents

\end{document}
  • This works. I ended up using a modified version \fancypagestyle{plain}{ \fancyhead{} \renewcommand{\headrulewidth}{0pt} \cfoot{\thepage} } \pagestyle{plain} – aboSamoor Jun 24 '15 at 11:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.