1

I'm using the style verbose-ibid. My bibliography contains German, English and French articles. In the first appearance (fullcite) article names are in quotation marks according to their language. But in the second appearance (shortcite) they all come with the same quotation marks. I think in verbose-ibid.cbx it is

\newbibmacro*{cite:short}{%
\printnames{labelname}%
\setunit*{\nametitledelim}%
\printtext[bibhyperlink]{%
  \printfield[citetitle]{labeltitle}}}

and in biblatex.def it is

\DeclareFieldFormat
[article,inbook,incollection,inproceedings,patent,thesis,unpublished]
{citetitle}{\mkbibquote{#1\isdot}}

who are responsible but I'm by far not an expert. How can I change it to somehow use foreignquote instead of \mkbibquote?

3
  • 3
    Welcome. It would really help to have a small, compilable document showing the problem. Much easier for people to work on a solution which might actually help.
    – cfr
    Jun 24, 2015 at 19:45
  • 1
    Welcome. Yes please show us a MWE that actually exhibits the problem. Does language=auto (instead of the default language=autobib) as loading-time option help? The problem should not lie with \mkbibquote which as far as I know is language-sensitive, but with the fact that biblatex does not switch the languages in citations while it does in the bibliography (by default) and so also in a fullcite because a fullcite is essentially just a call to the bib-driver.
    – moewe
    Jun 24, 2015 at 20:06
  • <code>langauge=auto</code> solves the problem. Thanks a lot!!
    – Phlorian
    Jun 24, 2015 at 21:14

1 Answer 1

2

To also make the citations use the environment specified via the autolang option, set

language=auto

The default value for this option is autobib which means that only in the bibliography language switching is enabled.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.