4

I have a problem when reinstalling vim-latex (possibly installing a newer version). Here is the code I typed

\documentclass{article}
\begin{document}
$\pi$

$2^5$

\textbf{abc}

$2^{\pi}$
\end{document}

$\pi$ became π, $2^5$ became 25, \textbf{abc} became abc and so on.

Screenshot:

Here's a screenshot of it

How do I turn it off?

0

The issue is the vim variable conceallevel is being set to 2.

How to fix this depends on your specific vim setup, if you run :verbose set conceallevel? in vim, then you will see where conceallevel is being set. If it's in your .vimrc then delete that line. If it's in a plugin (such as indentLine, which sets conceallevel to 2) then you can read through the plugins documentation and disable that plugin (in the case of indentLine you can either use autocmd BufNewFile,BufRead *.tex IndentLinesDisable or let g:indentLine_noConcealCursor=2 which only causes the text to be expanded when your cursor is on that line.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.