0


My glossary is duplicating each entry's definition and I've been beating my head against the wall looking for help. The only thing I've been able to find here is for titles, but not definitions. I tried using those questions to figure out what was going on anyway but didn't have any luck. Also couldn't really find anything on Google, so I'm a bit stumped here:

Here's an example glossary entry:

COW
Copy-On-Write. COWCopy-On-Write

It should be:

COW
Copy-On-Write.

Here's my sanitized main.tex preamble:

\documentclass[table]{book}

\textwidth 6.5in
\oddsidemargin 0.0in
\evensidemargin 0.0in
\textheight 8.5in
\topmargin 0.0in

\usepackage{amsmath, amsthm, amssymb, amsfonts}
\usepackage{texdraw}
\usepackage{pstricks,pst-node,pst-tree}
\usepackage{fancyvrb}
\fvset{gobble=8,xleftmargin=24pt}
\newpsobject{showgrid}{psgrid}{subgriddiv=1,griddots=10,gridlabels=6pt}
\psset{unit=2cm}
\usepackage{fancyhdr}
\pagestyle{fancyplain}
\usepackage{url}
\usepackage{xcolor}
\usepackage{hyperref} 
\usepackage{graphicx}
\usepackage{array}
\usepackage{pbox}
\usepackage{multirow}
\usepackage{hhline}
\usepackage{color}
\usepackage[labelfont=bf,width=0.75\textwidth]{caption}
\usepackage{colortbl}
\usepackage{tabularx}
\usepackage{arydshln}
\usepackage{subcaption}
\usepackage[T1]{fontenc}
\usepackage[strings]{underscore} 
\usepackage[nottoc,numbib]{tocbibind}
\usepackage[xindy,nonumberlist,toc]{glossaries}
\usepackage{enumitem}
%...
\makeglossaries
%...
\input{common}

And here's the main.gls entry for the above example:

\glossentry{cow}{\glsnamefont{COW}}{Copy-On-Write}{\relax }{\glossaryentrynumbers{\relax

It seems like this is probably something painfully simple that I'm just overlooking, but I would appreciate any help or suggestions your collective awesomeness could provide.

Much appreciated!
-Colin

  • 1
    You've included a bunch of code which has nothing to do with the problem and not included the code necessary to reproduce the problem. Please make a small, compilable document which we can compile to see what you are seeing. – cfr Jun 25 '15 at 23:19
  • Ah, apologies. Wasn't sure what was needed for these kinds of questions, thought the preamble might be useful in case it was a package issue. I'll see what I can do about providing a compilable doc. Thanks. – Colin Torretta Jun 29 '15 at 15:27
0

Fixed it. Needed to regenerate the glo/gls files outside of the normal Makefile build process we use. Once regenerated, Makefile builds correctly make the glossary.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.