0

This question is indeed similar to this one: I open my Bibliographie.bib file in Texmaker and push the F11 button to "run" the file but then get

Process started

I couldn't open file name `Bibliographie.aux'

Process exited normally

My problem however was not solved by following the suggestions of the other post: I did go to > Option > Configure Texmaker then click on the "Use a "build" subdirectory for output files" and change the Bib(la)tex line to bibtex build\% (I also tried "bibtex build/% -include-directory=build")

and that would just give me the same message:

Process started

I couldn't open file name `build/Bibliographie.aux'

Process exited normally

My bibliography file certainly has no inner mistakes since it worked perfectly on my old computer. The problem appeared as I changed to a new computer with a more recent version of Texmaker, but my files themselves have not changed.

OOhhh: I do not have any Bibliographie.aux file at least in the same directory as my other files... but as far as I remember, it was also the case in my old computer.

  • One of the reason why I never output files to some special build directory. It is simply confusing. Try to find out where the aux-file is and point bibtex to this folder. – Ulrike Fischer Jun 26 '15 at 8:58
  • I originally did not put the output files in any build directory but the problem came up anyway. And I don't remember that there were any more files than Bibliographie.bib for the bibliography itself. What I had was my main file ***.tex and then ***.aux and many other that appear when I compile the main file. – Noix07 Jun 26 '15 at 9:03
  • 1
    I bet your document is called something like main.tex or thesis.tex or master.tex. Run BibTeX wih arguments main or thesis or master or ..., but not Bibliographie. – Johannes_B Jun 26 '15 at 9:07
  • I usualy don't use command lines, so I translate what I should do: open my main.tex file, and push the F11 button? that I actually already did: it actually works for the old references that I had added, but I have added a new one, and for this one, I would see [?] in the pdf file, so I thought I had to "run" the Bibliography.bib file – Noix07 Jun 26 '15 at 9:20
  • which is the way I have always done... and thas used to work – Noix07 Jun 26 '15 at 9:21
1

Ok, my mistake: instead of "running" pdf lateX, I would just use the F1 button.

This is what I used to do with my old computer and I thought it was pdflatex compiling.

Every finally worked when I indeed run Bibtex = F11, then pdflatex = F6 (not F1), then again (F6)

  • F1 is quick build, you can configure what that does in the settings. Typically Quick build would run something like pdflatex + view pdf I think, but perhaps the settings are different in your system. – Torbjørn T. Jun 26 '15 at 10:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.