7

This question already has an answer here:

Is there any way to cite all articles in the bibliography (i.e. BiBTeX entries with @article type)?

I know there is a type option in the \printbibliography command. I want something like \cite[type=article]{*}...

UPD: For example, I have 100 articles in the bib file and 100 proceedings. I want to print the bibliography that shows the articles first, then the proceedings.

If I use the following code

\nocite{*}
\printbibliography[type=article,title={Articles}]
\printbibliography[type=inproceedings,title={Proceedings}]

I will have bad numeration (since the articles and the proceeding are "mixed" in the bib-file:

Articles:
1. Article#1
3. Article#2
4. Article#3
...
183. Arctice#100

Proceedings:
2. Proceeding#1
5. Proceeding#5
...
200. Proceeding#100

P.S. Manually citing all the papers in the correct order (\cite{article1, article2, ..., article100, proceeding1, proceeding2, ..., proceeding100}) is not a good option.

marked as duplicate by moewe, Jesse, Torbjørn T., Johannes_B, Gonzalo Medina Jul 10 '15 at 14:49

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 2
    \nocite{*}\printbibliography[type=article,title={Bibliography}]? – Johannes_B Jun 26 '15 at 9:35
  • 2
    If your main aim is to get a specific sorting in the bibliography you should better define this sorting. – Ulrike Fischer Jun 26 '15 at 13:43
  • 1
    Since you only want your bibliography to sort by type, what about tex.stackexchange.com/q/6959/35864? Maybe together with tex.stackexchange.com/q/241231/35864 or tex.stackexchange.com/a/236650/35864 for spacing between the different bibliographies. – moewe Jul 2 '15 at 6:26
  • 4
    Aha! But did you use defernumbers=true as explained in the example? If the problem persists, please consider posting a full MWE for us to play around with (using bIblatex-examples.bib so you don't even have to use your private .bib file). – moewe Jul 2 '15 at 6:54
  • 2
    You are right! defernumbers=true solves the problem. – bcp Jul 2 '15 at 8:08