1

I want to add a url access date of the website I accessed to my bibliography but only at the end (after the url).

The MWE is as follows

\documentclass[a4paper,12pt,numbers=noenddot]{scrartcl}    
\usepackage[style=numeric, 
natbib=true,
maxitems=1,
backend=biber]{biblatex}
\usepackage[breaklinks=true,
linktocpage=true,   

pdftitle={My Title},
pdfsubject={},
pdfauthor={My Name},
pdfkeywords={}]{hyperref}   


\bibliography{project}
\begin{document}
enter code here


@Online{ansys_2009,
Title                    = {Contact Technology Guide},
Author                   = {SAP IP Inc.},

   Url                      = {http://orange.engr.ucdavis.edu/Documentation12.1/121/ans_ctec.pdf},
Year                     = {2009},
Month                    = {November},
Urldate                  = {Accessed on 25-04-2015},
Version                  = {12.1}}

\printbibliography


\end{document}

Output :

enter image description here

I am using Jabref 2.10 reference manager to access my .bib file. I have already gone through similar questions asked in this forum but it doesn't seem to work for me. Also there is no @online in Jabref. So I type it as @misc.

  • Go to option/preferences and then advanced. activate biblatex-mode and everything will be fine. – Johannes_B Jun 27 '15 at 10:43
  • @Johannes_B I am able to see the urldate field and note field now. When I enter accessed date in note field I get it before the url (as previous) and when I enter in the urldate field it still doesn't get published. I tried 'www', 'online' and 'misc' fields. – Bruce Jun 27 '15 at 11:13
  • It might be that your biblatex-style simply doesn't use the urldate, though unlikely. Can you update the question above with your bibliography entry as well as the biblatex settings? A compilable example would be even better ;-) – Johannes_B Jun 27 '15 at 11:18
  • by the way, added a picture: github.com/johannesbottcher/HinweiseLitverzeichnisse/blob/split/… – Johannes_B Jun 27 '15 at 11:22
  • @Johannes_B I have described a MWE. – Bruce Jun 27 '15 at 11:45
1

The first thing to do is to tell JabRef about the use of biblatex. Go to options, preferences. In the advanced tab, select BibLaTeX-mode. You will now see all the fields available with biblatex, also types like online.


As far as the biblatex/biber combo is concerned, the stuff written into the urldate field is complete gibberish and hence is ignored. Everything in there should be just a date. Please have a look at the following output, depending on the language active, the entries look different.

bruceBiblatexxUrldate

\begin{filecontents}{\jobname.bib}
    @Online{ansys_2009,
        Title                    = {Contact Technology Guide},
        Author                   = {SAP IP Inc.},

        Url                      = {http://orange.engr.ucdavis.edu/Documentation12.1/121/ans_ctec.pdf},
        Year                     = {2009},
        Month                    = {November},
        Urldate                  = {2015-04-25},
        Version                  = {12.1}
    }
\end{filecontents}
\documentclass[a4paper,10pt,DIV=16,numbers=noenddot,english,french,ngerman]{scrartcl}    
\usepackage{babel}
\usepackage[style=numeric, 
    natbib=true,
    maxitems=1,
backend=biber]{biblatex}
\usepackage[breaklinks=true,
    linktocpage=true,   
    pdftitle={My Title},
    pdfsubject={},
    pdfauthor={My Name},
pdfkeywords={}]{hyperref}   


%\bibliography{\jobname}% PLease note, that is deprecated
\addbibresource{\jobname.bib}
\begin{document}
\fullcite{ansys_2009}\par
\selectlanguage{french}
\fullcite{ansys_2009}\par
\selectlanguage{english}
\fullcite{ansys_2009}\par

\printbibliography
\end{document}

I changed fontsize and type area to get a nice screenshot, just ignore those changes ;-)

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for?Browse other questions tagged or ask your own question.